summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2017-01-04 20:06:29 -0500
committerWilliam Turner2017-01-04 20:06:29 -0500
commit9a115ff1f496d2b067335c54e6d80b214ec364ed (patch)
tree044bfaab479828bd3aae26bdd17850276389be2f
downloadaur-9a115ff1f496d2b067335c54e6d80b214ec364ed.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..506460703454
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-mutatormath
+ pkgdesc = A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/LettError/MutatorMath
+ arch = any
+ license = BSD
+ makedepends = python-pip
+ makedepends = python2-pip
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/py2.py3/M/MutatorMath/MutatorMath-2.0.0-py2.py3-none-any.whl
+ sha256sums = a29587df7c6670ba232caf4cb1b2c9bd1dd338fe6ac969d531f1bd7d6f29cce7
+
+pkgname = python-mutatormath
+ depends = python
+ provides = python-mutatormath
+
+pkgname = python2-mutatormath
+ depends = python2
+ provides = python2-mutatormath
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b7c732c359b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: William Turner <willtur.will@gmail.com>
+pkgbase=python-mutatormath
+pkgname=(python-mutatormath python2-mutatormath)
+_pkgname=MutatorMath
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.'
+arch=('any')
+url='https://github.com/LettError/MutatorMath'
+license=('BSD')
+depends=('')
+makedepends=('python-pip' 'python2-pip')
+options=(!emptydirs)
+source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}-py2.py3-none-any.whl")
+sha256sums=('a29587df7c6670ba232caf4cb1b2c9bd1dd338fe6ac969d531f1bd7d6f29cce7')
+
+package_python-mutatormath() {
+ depends=('python')
+ provides=('python-mutatormath')
+
+ cd "${srcdir}"
+
+ # install the wheel
+ PIP_CONFIG_FILE=/dev/null pip install \
+ --isolated \
+ --root="${pkgdir}" \
+ --ignore-installed \
+ --no-deps \
+ ${_pkgname}-${pkgver}-py2.py3-none-any.whl
+
+ # compile to pyo
+ python -O -m compileall "${pkgdir}"
+}
+
+package_python2-mutatormath() {
+ depends=('python2')
+ provides=('python2-mutatormath')
+
+ cd "${srcdir}"
+
+ # install the wheel
+ PIP_CONFIG_FILE=/dev/null pip2 install \
+ --isolated \
+ --root="${pkgdir}" \
+ --ignore-installed \
+ --no-deps \
+ ${_pkgname}-${pkgver}-py2.py3-none-any.whl
+
+ # compile to pyo
+ python2 -O -m compileall "${pkgdir}"
+}