summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Turner2017-01-04 22:59:01 -0500
committerWilliam Turner2017-01-04 22:59:01 -0500
commite6a8892896e4daecab68890d68f86fd5a40e187d (patch)
tree7d0107b3e2a0b15e9ba00fd787b3b6b71f4bf005
parentbbaf5e06abb2e3f12055b0b6db2fef8f8bb263dd (diff)
downloadaur-e6a8892896e4daecab68890d68f86fd5a40e187d.tar.gz
Corrects dependencies
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD8
2 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 506460703454..73b063f853ef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,39 @@
pkgbase = python-mutatormath
pkgdesc = A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/LettError/MutatorMath
arch = any
license = BSD
makedepends = python-pip
makedepends = python2-pip
+ depends = python
+ depends = python-fonttools
+ depends = python-ufolib
+ depends = python-defcon
+ depends = python-fontmath
+ depends = python2
+ depends = python2-fonttools
+ depends = python2-ufolib
+ depends = python2-defcon
+ depends = python2-fontmath
options = !emptydirs
source = https://files.pythonhosted.org/packages/py2.py3/M/MutatorMath/MutatorMath-2.0.0-py2.py3-none-any.whl
sha256sums = a29587df7c6670ba232caf4cb1b2c9bd1dd338fe6ac969d531f1bd7d6f29cce7
pkgname = python-mutatormath
depends = python
+ depends = python-fonttools
+ depends = python-ufolib
+ depends = python-defcon
+ depends = python-fontmath
provides = python-mutatormath
pkgname = python2-mutatormath
depends = python2
+ depends = python2-fonttools
+ depends = python2-ufolib
+ depends = python2-defcon
+ depends = python2-fontmath
provides = python2-mutatormath
diff --git a/PKGBUILD b/PKGBUILD
index 845999e8d472..4271d7b9bf1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,20 @@ pkgbase=python-mutatormath
pkgname=(python-mutatormath python2-mutatormath)
_pkgname=MutatorMath
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='A library for the calculation of piecewise linear interpolations in n-dimensions with any number of masters.'
arch=('any')
url='https://github.com/LettError/MutatorMath'
license=('BSD')
+depends=('python' 'python-fonttools' 'python-ufolib' 'python-defcon' 'python-fontmath'
+ 'python2' 'python2-fonttools' 'python2-ufolib' 'python2-defcon' 'python2-fontmath')
makedepends=('python-pip' 'python2-pip')
options=(!emptydirs)
source=("https://files.pythonhosted.org/packages/py2.py3/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}-py2.py3-none-any.whl")
sha256sums=('a29587df7c6670ba232caf4cb1b2c9bd1dd338fe6ac969d531f1bd7d6f29cce7')
package_python-mutatormath() {
- depends=('python')
+ depends=('python' 'python-fonttools' 'python-ufolib' 'python-defcon' 'python-fontmath')
provides=('python-mutatormath')
cd "${srcdir}"
@@ -32,7 +34,7 @@ package_python-mutatormath() {
}
package_python2-mutatormath() {
- depends=('python2')
+ depends=('python2' 'python2-fonttools' 'python2-ufolib' 'python2-defcon' 'python2-fontmath')
provides=('python2-mutatormath')
cd "${srcdir}"