summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-26 21:49:19 -0500
committerCarlos Aznarán Laos2021-11-26 21:49:19 -0500
commit8fa6308504d051318f555d0d9bb52cacea94708b (patch)
tree4aacf00e81174c947bec87710df87ec60414bb50
parentd0b6c4de5a306433d000d268dada80dce4af4b69 (diff)
downloadaur-8fa6308504d051318f555d0d9bb52cacea94708b.tar.gz
Version bump to 0.3.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 466af1f5bdb2..dd55cb944fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-mwoauth
pkgdesc = Generic MediaWiki OAuth handshake helper for Python
- pkgver = 0.3.0
- pkgrel = 3
+ pkgver = 0.3.7
+ pkgrel = 1
url = https://github.com/mediawiki-utilities/python-mwoauth
arch = any
license = MIT
makedepends = python-setuptools
depends = python-pyjwt
depends = python-requests-oauthlib
- source = https://github.com/mediawiki-utilities/python-mwoauth/archive/v0.3.0.tar.gz
- sha512sums = 4d07726687e55669d63de00c5ef2a65400e7c62c269e99c26e3b26873d93074434f96fb886eaa57fffc7738e2f763a84f833b44ff33e27a523a0e9ab930d6dd4
+ source = https://pypi.org/packages/source/m/mwoauth/mwoauth-0.3.7.tar.gz
+ sha512sums = e16db48633d4f476b4f46e22dce06ae355e2ff07926ea7c2ccad56a3548d471711556f87bc8abcae454b61943c1f8c1b24b42fec1a28906f0d4196c045bf339a
pkgname = python-mwoauth
diff --git a/PKGBUILD b/PKGBUILD
index 53652d821fa5..8b8f4a9360e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Simon Legner <Simon.Legner@gmail.com>
-pkgname=python-mwoauth
-pkgver=0.3.0
-pkgrel=3
+_base=mwoauth
+pkgname=python-${_base}
+pkgver=0.3.7
+pkgrel=1
pkgdesc="Generic MediaWiki OAuth handshake helper for Python"
license=(MIT)
arch=('any')
url="https://github.com/mediawiki-utilities/${pkgname}"
depends=(python-pyjwt python-requests-oauthlib)
makedepends=(python-setuptools)
-source=(${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('4d07726687e55669d63de00c5ef2a65400e7c62c269e99c26e3b26873d93074434f96fb886eaa57fffc7738e2f763a84f833b44ff33e27a523a0e9ab930d6dd4')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('e16db48633d4f476b4f46e22dce06ae355e2ff07926ea7c2ccad56a3548d471711556f87bc8abcae454b61943c1f8c1b24b42fec1a28906f0d4196c045bf339a')
build() {
- cd "${pkgname}-${pkgver}"
+ cd "${_base}-${pkgver}"
python setup.py build
}
package() {
- cd "${pkgname}-${pkgver}"
+ cd "${_base}-${pkgver}"
+ export PYTHONHASHSEED=0
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}