summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2021-08-04 16:08:15 +0200
committerSimon Legner2021-08-04 16:08:15 +0200
commitf2f300042e93eb3742db28a144bc6e1e095fcb29 (patch)
tree465470f95c8895d1321777ccbb56a48827194215
downloadaur-f2f300042e93eb3742db28a144bc6e1e095fcb29.tar.gz
Initial upload: python-mwoauth 0.3.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fb987f3c7d6d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-mwoauth
+ pkgdesc = A generic MediaWiki OAuth handshake helper for Python
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/mediawiki-utilities/python-mwoauth
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = python-mwoauth-0.3.0.tar.gz::https://github.com/mediawiki-utilities/python-mwoauth/archive/refs/tags/v0.3.0.tar.gz
+ sha512sums = 4d07726687e55669d63de00c5ef2a65400e7c62c269e99c26e3b26873d93074434f96fb886eaa57fffc7738e2f763a84f833b44ff33e27a523a0e9ab930d6dd4
+
+pkgname = python-mwoauth
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c2997c954dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+pkgname=python-mwoauth
+pkgdesc="A generic MediaWiki OAuth handshake helper for Python"
+pkgver=0.3.0
+pkgrel=1
+arch=('any')
+url="https://github.com/mediawiki-utilities/python-mwoauth"
+license=('MIT')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/mediawiki-utilities/$pkgname/archive/refs/tags/v${pkgver}.tar.gz")
+depends=('python')
+makedepends=('python-setuptools')
+
+check() {
+ cd $srcdir/$pkgname-$pkgver
+ python setup.py check
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm755 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+sha512sums=('4d07726687e55669d63de00c5ef2a65400e7c62c269e99c26e3b26873d93074434f96fb886eaa57fffc7738e2f763a84f833b44ff33e27a523a0e9ab930d6dd4')