summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-05-31 21:50:37 -0700
committerclintval2018-05-31 21:50:37 -0700
commit1adba4f61aeff335ec5fc8d3d650a302bedd6fb7 (patch)
tree0fa5f410e7049878ca6394faff99082b60eaee2c
downloadaur-1adba4f61aeff335ec5fc8d3d650a302bedd6fb7.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD56
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50b53b1d1db6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = python-mygene
+ pkgdesc = An easy-to-use Python wrapper to access MyGene.Info services.
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = https://github.com/meowklaski/mygene
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ makedepends = python2
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = python-mygene-3.0.0.tar.gz::https://pypi.io/packages/source/m/mygene/mygene-3.0.0.tar.gz
+ source = https://raw.githubusercontent.com/biothings/mygene.py/ver_3.0.0/LICENSE.txt
+ sha256sums = 36e5e42e05ade82141b7a82e5f9249546fabe5e9f47fe18c1535e6cedc603314
+ sha256sums = 18539fdbf9b2e53473f2245529be890192c7b9ead40b4168c1f64fb972d66f87
+
+pkgname = python-mygene
+ depends = python
+ depends = python-requests
+
+pkgname = python2-mygene
+ depends = python2
+ depends = python2-requests
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acc0a21e4c99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+_name=mygene
+pkgbase='python-mygene'
+pkgname=('python-mygene' 'python2-mygene')
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="An easy-to-use Python wrapper to access MyGene.Info services."
+arch=('any')
+url=https://github.com/meowklaski/"${_name}"
+license=('MIT')
+makedepends=(
+ 'python' 'python-setuptools'
+ 'python2' 'python2-setuptools')
+options=(!emptydirs)
+source=(
+ "${pkgname}"-"${pkgver}".tar.gz::https://pypi.io/packages/source/"${_name:0:1}"/"${_name}"/"${_name}"-"${pkgver}".tar.gz
+ https://raw.githubusercontent.com/biothings/"${_name}".py/ver_"${pkgver}"/LICENSE.txt
+)
+sha256sums=(
+ '36e5e42e05ade82141b7a82e5f9249546fabe5e9f47fe18c1535e6cedc603314'
+ '18539fdbf9b2e53473f2245529be890192c7b9ead40b4168c1f64fb972d66f87'
+)
+
+prepare() {
+ cp -a "${_name}"-"${pkgver}"{,-py2}
+}
+
+package() {
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+build(){
+ cd "${srcdir}"/"${_name}"-"${pkgver}"
+ python setup.py build
+
+ cd "${srcdir}"/"${_name}"-"${pkgver}"-py2
+ python2 setup.py build
+}
+
+package_python2-mygene() {
+ depends=('python2' 'python2-requests')
+
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE.txt
+ cd "${_name}"-"${pkgver}"-py2
+ python2 setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}
+
+package_python-mygene() {
+ depends=('python' 'python-requests')
+
+ install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE.txt
+ cd "${_name}"-"${pkgver}"
+ python setup.py install --root="${pkgdir}"/ --optimize=1 --skip-build
+}