summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Löthberg2021-09-18 02:12:43 +0200
committerJohannes Löthberg2021-09-18 02:12:43 +0200
commitd3620da1fd6c863488075b75c099f579ec5806ae (patch)
tree6eaa0f955f67b3204af83bff8b58d9f380ce7ade
downloadaur-d3620da1fd6c863488075b75c099f579ec5806ae.tar.gz
Importing from community
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b5f7ee7074e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-mypy-protobuf
+ pkgdesc = Generate mypy stub files from protobuf specs
+ pkgver = 2.9
+ pkgrel = 1
+ url = https://github.com/dropbox/mypy-protobuf
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = mypy
+ depends = protobuf
+ depends = python
+ depends = python-protobuf
+ source = https://files.pythonhosted.org/packages/source/m/mypy-protobuf/mypy-protobuf-2.9.tar.gz
+ sha256sums = 278172935d7121c2f8c7c0a05518dd565a2b76d9e9c4a0a3fcd08a21fa685d43
+
+pkgname = python-mypy-protobuf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6fb67800f00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Don't bump to 2.X until we have Anki >= 2.1.41
+pkgname=python-mypy-protobuf
+pkgver=2.9
+pkgrel=1
+
+pkgdesc='Generate mypy stub files from protobuf specs'
+url='https://github.com/dropbox/mypy-protobuf'
+arch=('any')
+license=('Apache')
+
+depends=('mypy' 'protobuf' 'python' 'python-protobuf')
+makedepends=('python-setuptools')
+
+source=("https://files.pythonhosted.org/packages/source/m/mypy-protobuf/mypy-protobuf-$pkgver.tar.gz")
+
+sha256sums=('278172935d7121c2f8c7c0a05518dd565a2b76d9e9c4a0a3fcd08a21fa685d43')
+
+build() {
+ cd mypy-protobuf-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd mypy-protobuf-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}