summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSameer Puri2024-03-01 09:52:49 -0800
committerSameer Puri2024-03-01 09:52:49 -0800
commitddfcd6c5727fc310e6761dcf6719051883150484 (patch)
tree166c88fd023cf3589479544751f2a537165e02b6
parentd3620da1fd6c863488075b75c099f579ec5806ae (diff)
downloadaur-ddfcd6c5727fc310e6761dcf6719051883150484.tar.gz
update to 3.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b5f7ee7074e..930e0c0b66e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-mypy-protobuf
pkgdesc = Generate mypy stub files from protobuf specs
- pkgver = 2.9
+ pkgver = 3.5.0
pkgrel = 1
url = https://github.com/dropbox/mypy-protobuf
arch = any
license = Apache
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = mypy
depends = protobuf
depends = python
depends = python-protobuf
- source = https://files.pythonhosted.org/packages/source/m/mypy-protobuf/mypy-protobuf-2.9.tar.gz
- sha256sums = 278172935d7121c2f8c7c0a05518dd565a2b76d9e9c4a0a3fcd08a21fa685d43
+ source = https://files.pythonhosted.org/packages/source/m/mypy-protobuf/mypy-protobuf-3.5.0.tar.gz
+ sha256sums = 21f270da0a9792a9dac76b0df463c027e561664ab6973c59be4e4d064dfe67dc
pkgname = python-mypy-protobuf
diff --git a/PKGBUILD b/PKGBUILD
index b6fb67800f00..164eb0a3b249 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Don't bump to 2.X until we have Anki >= 2.1.41
pkgname=python-mypy-protobuf
-pkgver=2.9
+pkgver=3.5.0
pkgrel=1
pkgdesc='Generate mypy stub files from protobuf specs'
@@ -9,18 +9,18 @@ arch=('any')
license=('Apache')
depends=('mypy' 'protobuf' 'python' 'python-protobuf')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/m/mypy-protobuf/mypy-protobuf-$pkgver.tar.gz")
-sha256sums=('278172935d7121c2f8c7c0a05518dd565a2b76d9e9c4a0a3fcd08a21fa685d43')
+sha256sums=('21f270da0a9792a9dac76b0df463c027e561664ab6973c59be4e4d064dfe67dc')
build() {
cd mypy-protobuf-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd mypy-protobuf-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}