summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-02-26 19:11:00 +0100
committerXiretza2020-02-26 19:11:00 +0100
commitf77cb983c9873798909bf232475dae5298adaab1 (patch)
tree8391e117bac3998dbb10f4f10b0d3cb20807a6ad
downloadaur-f77cb983c9873798909bf232475dae5298adaab1.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD36
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00e80bf81d9b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-mypy_protobuf-git
+ pkgdesc = Generate mypy stub files from protobuf specs
+ pkgver = v1.13.r32.gf2a078b
+ pkgrel = 1
+ url = https://github.com/dropbox/mypy-protobuf
+ arch = any
+ license = Apache
+ checkdepends = python-pytest
+ makedepends = git
+ depends = python-setuptools
+ depends = python-protobuf
+ source = git+https://github.com/dropbox/mypy-protobuf
+ sha256sums = SKIP
+
+pkgname = python-mypy_protobuf-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a5e42b0b5de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: xiretza <xiretza+aur@xiretza.xyz>
+
+pkgname=python-mypy_protobuf-git
+_name=mypy-protobuf
+pkgver=v1.13.r32.gf2a078b
+pkgrel=1
+pkgdesc="Generate mypy stub files from protobuf specs"
+arch=(any)
+url="https://github.com/dropbox/mypy-protobuf"
+license=('Apache')
+depends=('python-setuptools' 'python-protobuf')
+makedepends=('git')
+checkdepends=('python-pytest')
+source=("git+https://github.com/dropbox/mypy-protobuf")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_name/python"
+ python setup.py build
+}
+
+#check() {
+# cd "$_name"
+# protoc --python_out=. --mypy_out=. --proto_path=proto/ $(find proto/test -name "*.proto")
+# pytest
+#}
+
+package() {
+ cd "$_name/python"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}