summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramadejpapez2021-07-30 18:53:26 +0200
committeramadejpapez2021-07-30 18:53:26 +0200
commit2d925f375809c0da217e068c8ad669ebde67ee99 (patch)
treefe96c9188f8dd41277c3b61ecc0201f6980b6e8d
parent5693ef172934907f0acfbbc54eb8d4e6faad788f (diff)
downloadaur-2d925f375809c0da217e068c8ad669ebde67ee99.tar.gz
New upstream version 1.10.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 26 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a066a0c366f3..f169fdb2e684 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-name-that-hash
- pkgdesc = The Modern Hash Identifcation System
- pkgver = 1.6.0
- pkgrel = 4
+ pkgdesc = The Modern Hash Identification System
+ pkgver = 1.10.0
+ pkgrel = 1
url = https://github.com/HashPals/Name-That-Hash
arch = any
- license = (L)GPL3
+ license = GPL3
makedepends = python-setuptools
+ makedepends = python-dephell
depends = python
depends = python-click
depends = python-rich
- source = https://files.pythonhosted.org/packages/source/n/name-that-hash/name-that-hash-1.6.0.tar.gz
- md5sums = d4e70b2bbc2fedc7f591b9047fd6641d
+ source = https://files.pythonhosted.org/packages/source/n/name-that-hash/name-that-hash-1.10.0.tar.gz
+ sha256sums = aabe1a3e23f5f8ca1ef6522eb1adcd5c69b5fed3961371ed84a22fc86ee648a2
pkgname = python-name-that-hash
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 2c5ac5c948bd..3c5ed05edb69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-#Maintainer: Machina <machinax@protonmail.com>
+# Maintainer: amadejpapez
+# Previous maintainer: Machina <machinax@protonmail.com>
+
pkgname='python-name-that-hash'
-_module='name-that-hash'
-pkgver=1.6.0
-pkgrel=4
-pkgdesc="The Modern Hash Identifcation System"
+_pkgname='name-that-hash'
+pkgver=1.10.0
+pkgrel=1
+pkgdesc="The Modern Hash Identification System"
+arch=('any')
url="https://github.com/HashPals/Name-That-Hash"
-makedepends=('python-setuptools')
+license=('GPL3')
depends=('python' 'python-click' 'python-rich')
-license=('(L)GPL3')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-md5sums=('d4e70b2bbc2fedc7f591b9047fd6641d')
+makedepends=('python-setuptools' 'python-dephell')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('aabe1a3e23f5f8ca1ef6522eb1adcd5c69b5fed3961371ed84a22fc86ee648a2')
build()
{
- cd "$_module-$pkgver"
+ cd "$_pkgname-$pkgver"
python setup.py build
}
package()
{
- cd "$_module-$pkgver"
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps loguru
- python setup.py install --prefix="/usr" --root="$pkgdir" --optimize=1 --skip-build
+ cd "$_pkgname-$pkgver"
+ python setup.py install --prefix="/usr" --root="$pkgdir/" --optimize=1 --skip-build
}