summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramadejpapez2022-11-18 19:28:05 +0100
committeramadejpapez2022-11-18 19:28:05 +0100
commitc85ae1bd78bff8fffc8c955d012906fe270fc1a2 (patch)
tree4525b8622f4b323c22663e2ef697319f038b1837
parentaff97c8d5b7a4452a69432dde6452fb0efdc7e89 (diff)
downloadaur-c85ae1bd78bff8fffc8c955d012906fe270fc1a2.tar.gz
temporarily install directly via a pypi wheel
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 52418cfc9195..edbf1a84299d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-name-that-hash
pkgdesc = The Modern Hash Identification System.
pkgver = 1.11.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/HashPals/Name-That-Hash
arch = any
license = GPL3
- makedepends = python-build
makedepends = python-installer
makedepends = python-poetry-core
+ makedepends = python-wheel
depends = python
depends = python-click
depends = python-rich
- source = https://github.com/HashPals/Name-That-Hash/archive/1.11.0/python-name-that-hash-1.11.0.tar.gz
- sha256sums = 2f8dd4beaf7326d2f664f18205c024848dcb627ff29ceffb22ab410fbef2d761
+ source = https://files.pythonhosted.org/packages/19/7a/731c96302f39610f1ce6742a4e5b997d621b06f5608dc939f5cd48a639a0/name_that_hash-1.11.0-py3-none-any.whl
+ sha256sums = 59682a35714235d958e723d658c0874abb81edf77ceb9d81d7e6416bc2af3b84
pkgname = python-name-that-hash
diff --git a/PKGBUILD b/PKGBUILD
index f2b1c44cb293..e88f007b676f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,27 @@
pkgname=python-name-that-hash
_pkgname=Name-That-Hash
pkgver=1.11.0
-pkgrel=5
+pkgrel=6
pkgdesc="The Modern Hash Identification System."
arch=("any")
url="https://github.com/HashPals/Name-That-Hash"
license=("GPL3")
depends=("python" "python-click" "python-rich")
-makedepends=("python-build" "python-installer" "python-poetry-core")
-source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=("2f8dd4beaf7326d2f664f18205c024848dcb627ff29ceffb22ab410fbef2d761")
+makedepends=("python-installer" "python-poetry-core" "python-wheel")
+source=("https://files.pythonhosted.org/packages/19/7a/731c96302f39610f1ce6742a4e5b997d621b06f5608dc939f5cd48a639a0/name_that_hash-1.11.0-py3-none-any.whl")
+sha256sums=("59682a35714235d958e723d658c0874abb81edf77ceb9d81d7e6416bc2af3b84")
-build() {
- cd $_pkgname-$pkgver
- python -m build --wheel --skip-dependency-check --no-isolation
-}
+
+# NOTE: for now install directly via wheel as I was getting the
+# ModuleNotFoundError: No module named 'name_that_hash'
+# error after installation and cannot look into it right now
+
+# build() {
+# cd $_pkgname-$pkgver
+# python -m build --wheel --skip-dependency-check --no-isolation
+# }
package() {
- cd $_pkgname-$pkgver
- python -m installer --destdir="$pkgdir" dist/*.whl
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ python -m installer --destdir="$pkgdir" *.whl
+ # install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}