summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-25 15:33:53 -0500
committerCarlos Aznarán Laos2022-10-25 15:33:53 -0500
commita0539c5764f7fe9c4eaf9d4dd5f6f4fe8500df3c (patch)
treed80a59f5b4ef986d1cd014fcf19c68f6b3649d47
downloadaur-a0539c5764f7fe9c4eaf9d4dd5f6f4fe8500df3c.tar.gz
Bump version to 2.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5834300227f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-nanoid
+ pkgdesc = A tiny, secure, URL-friendly, unique string ID generator for Python
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/puyuan/py-nanoid
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.org/packages/source/n/nanoid/nanoid-2.0.0.tar.gz
+ sha512sums = 7db65075357feb19c4747be9abca1a19a2b8583f82cdcae87f06846141d798a725128ee784ce33cd3b14b272c0beb2dcac0faf4536e8d5183eaa06eab79fff87
+
+pkgname = python-nanoid
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba495d9b71a4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+_base=nanoid
+pkgname=python-${_base}
+pkgdesc="A tiny, secure, URL-friendly, unique string ID generator for Python"
+pkgver=2.0.0
+pkgrel=1
+arch=(any)
+url="https://github.com/puyuan/py-${_base}"
+license=(MIT)
+depends=(python)
+makedepends=(python-setuptools)
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('7db65075357feb19c4747be9abca1a19a2b8583f82cdcae87f06846141d798a725128ee784ce33cd3b14b272c0beb2dcac0faf4536e8d5183eaa06eab79fff87')
+
+build() {
+ cd ${_base}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+}