summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-08-11 20:16:19 -0400
committerGuillaume Horel2017-08-11 20:16:19 -0400
commitdb544f0891540fee50ce9644d0198a8ccc451c56 (patch)
treeb3958d0789c5babdb41239d659a904e533e135cc
parentef1a4bdd10870ca52637db0701b97f49b5c259e7 (diff)
downloadaur-db544f0891540fee50ce9644d0198a8ccc451c56.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 849c4ea5394c..d2ea9b4733cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-nbstripout
pkgdesc = Strips outputs from Jupyter and IPython notebooks
- pkgver = 0.3.0
+ pkgver = 0.3.1
pkgrel = 1
url = https://pypi.python.org/pypi/nbstripout/
arch = any
@@ -9,8 +9,10 @@ pkgbase = python-nbstripout
checkdepends = python-pytest-flake8
depends = git
depends = jupyter-nbformat
- source = https://pypi.org/packages/source/n/nbstripout/nbstripout-0.3.0.tar.gz
- sha256sums = 9b1801e81c59e2fad03bff2b738a0251e5b1207d784154f03b1328a2aa84dd88
+ source = https://pypi.org/packages/source/n/nbstripout/nbstripout-0.3.1.tar.gz
+ source = https://raw.githubusercontent.com/kynan/nbstripout/master/LICENSE.txt
+ sha256sums = b997c99b8bbb865988202d2f005cdaabb2598b07dad891c302a147a5871a4a95
+ sha256sums = 9842167c4bf9aa4662a669e8638d299a2460f6015ef0a98d4745871938bc1cd4
pkgname = python-nbstripout
diff --git a/PKGBUILD b/PKGBUILD
index 41d57ef13572..ad2747af300c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pyname=nbstripout
pkgname=python-$_pyname
-pkgver=0.3.0
+pkgver=0.3.1
pkgrel=1
pkgdesc='Strips outputs from Jupyter and IPython notebooks'
url="https://pypi.python.org/pypi/$_pyname/"
@@ -11,21 +11,18 @@ depends=('git' 'jupyter-nbformat')
checkdepends=('python-pytest' 'python-pytest-flake8')
license=('MIT')
arch=('any')
-source=("https://pypi.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
-sha256sums=('9b1801e81c59e2fad03bff2b738a0251e5b1207d784154f03b1328a2aa84dd88')
+source=("https://pypi.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz"
+"https://raw.githubusercontent.com/kynan/nbstripout/master/LICENSE.txt")
+sha256sums=('b997c99b8bbb865988202d2f005cdaabb2598b07dad891c302a147a5871a4a95'
+ '9842167c4bf9aa4662a669e8638d299a2460f6015ef0a98d4745871938bc1cd4')
build() {
cd $srcdir/$_pyname-$pkgver
python setup.py build
}
-check() {
- cd $srcdir/$_pyname-$pkgver
- pytest
-}
-
package() {
+ install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
cd $srcdir/$_pyname-$pkgver
python setup.py install --root="$pkgdir" --optimize=1
- install -D -m644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}