summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-13 11:25:11 -0400
committerGuillaume Horel2017-07-13 11:25:11 -0400
commitef1a4bdd10870ca52637db0701b97f49b5c259e7 (patch)
tree263f1fc2981180e39faf1622e86a31a5eb50f84d
parent482407a329a484b8704381bbe5452dfcd227143a (diff)
downloadaur-ef1a4bdd10870ca52637db0701b97f49b5c259e7.tar.gz
version bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c805d4e0282a..849c4ea5394c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri Mar 18 17:01:58 UTC 2016
pkgbase = python-nbstripout
pkgdesc = Strips outputs from Jupyter and IPython notebooks
- pkgver = 0.2.6
+ pkgver = 0.3.0
pkgrel = 1
url = https://pypi.python.org/pypi/nbstripout/
arch = any
license = MIT
checkdepends = python-pytest
+ checkdepends = python-pytest-flake8
depends = git
- depends = jupyter-notebook
- source = https://pypi.python.org/packages/source/n/nbstripout/nbstripout-0.2.6.tar.gz
- md5sums = 09e86f12b7a211d4a4040ed939d905a7
+ depends = jupyter-nbformat
+ source = https://pypi.org/packages/source/n/nbstripout/nbstripout-0.3.0.tar.gz
+ sha256sums = 9b1801e81c59e2fad03bff2b738a0251e5b1207d784154f03b1328a2aa84dd88
pkgname = python-nbstripout
diff --git a/PKGBUILD b/PKGBUILD
index 8810428bd0fd..41d57ef13572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: Antony Lee <anntzer dot lee at gmail dot com>
_pyname=nbstripout
pkgname=python-$_pyname
-pkgver=0.2.6
+pkgver=0.3.0
pkgrel=1
pkgdesc='Strips outputs from Jupyter and IPython notebooks'
url="https://pypi.python.org/pypi/$_pyname/"
-depends=('git' 'jupyter-notebook')
-checkdepends=('python-pytest')
+depends=('git' 'jupyter-nbformat')
+checkdepends=('python-pytest' 'python-pytest-flake8')
license=('MIT')
arch=('any')
-source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
-md5sums=('09e86f12b7a211d4a4040ed939d905a7')
+source=("https://pypi.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
+sha256sums=('9b1801e81c59e2fad03bff2b738a0251e5b1207d784154f03b1328a2aa84dd88')
build() {
cd $srcdir/$_pyname-$pkgver
@@ -20,7 +21,7 @@ build() {
check() {
cd $srcdir/$_pyname-$pkgver
- python setup.py test
+ pytest
}
package() {