summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicholas Dahm2023-01-05 09:09:09 -0500
committerNicholas Dahm2023-01-05 09:09:09 -0500
commit8dce26175a547d1baad86766291099e7f73c4b50 (patch)
treec63b324651b1aa49438835f39619e5659a879e31
parentc2d240fa18e286e2739b0ef88eda03f01f244bca (diff)
downloadaur-8dce26175a547d1baad86766291099e7f73c4b50.tar.gz
updated to 5.3.0
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e7810eb2c0a..b716067226c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,8 @@
# profit
pkgname=python-neo4j
-_pypiname=neo4j
-_pypidir="fe/a0/f085e0b6b3f93e207408a529d9bc738c0d3a3583a4e6a178a805928c14b6"
-pkgver=4.4.4
+_name=${pkgname#python-}
+pkgver=5.3.0
pkgrel=1
pkgdesc="Neo4j Bolt driver for Python"
url="https://pypi.org/project/neo4j/"
@@ -17,10 +16,10 @@ arch=('any')
license=('GPLv3')
depends=('python')
makedepends=('python-setuptools')
-source=(${_pypiname}-${pkgver}.tar.gz::"https://files.pythonhosted.org/packages/${_pypidir}/${_pypiname}-${pkgver}.tar.gz")
-sha256sums=('4f8982028021f9fc5e3e3605e6368302d6a97ea75a48666ae49fcc974113a3c8')
+source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('0c1c7d8812eed60da0a442d1e0f35edbda248255703e506a081cb70e083b3b5c')
package() {
- cd ${_pypiname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
- }
+ cd ${_name}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}