summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:17:13 +0100
committerDaniel Peukert2024-01-28 00:17:13 +0100
commit4cc39a7c0621b52112aec72e2da6ea65fc17a260 (patch)
tree05e43806a617fdc4758ee2e31030036c54d70f16
parent147bc96d603b02af542c954f965d102b4a732c7f (diff)
downloadaur-4cc39a7c0621b52112aec72e2da6ea65fc17a260.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD4
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e5a14f53c98..988e21dd4676 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = python-neotermcolor
license = MIT
makedepends = python-setuptools
depends = python
- source = python-neotermcolor-2.0.10-2.tar.gz::https://github.com/alttch/neotermcolor/archive/f4993d2590a2bfe6d89d075a38ede39e7dd0b896.tar.gz
+ source = python-neotermcolor-2.0.10.tar.gz::https://github.com/alttch/neotermcolor/archive/f4993d2590a2bfe6d89d075a38ede39e7dd0b896.tar.gz
sha512sums = cbfcb22170dcb8052e62078787e5c156ecdc27a1a0ad531f5c4ec8d3250ff88595a77dd47a80b02a7e5263303985135734f505fc0ee714210a61b43a85df3250
pkgname = python-neotermcolor
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index 97ce2f6debff..a7ebb31b9ab0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ url="https://github.com/alttch/$_projectname"
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$_commit.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$_commit.tar.gz")
sha512sums=('cbfcb22170dcb8052e62078787e5c156ecdc27a1a0ad531f5c4ec8d3250ff88595a77dd47a80b02a7e5263303985135734f505fc0ee714210a61b43a85df3250')
_sourcedirectory="$_projectname-$_commit"
@@ -23,5 +23,5 @@ build() {
package() {
cd "$srcdir/$_sourcedirectory/"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/MIT"
}