summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-02-14 01:33:40 +0800
committerUniversebenzene2019-02-14 01:33:40 +0800
commit77ac482c2a44778f6c98ed97457c807d1a6f3479 (patch)
tree34be12f678e34074e847f6f46b5400acb2d40a3b
downloadaur-77ac482c2a44778f6c98ed97457c807d1a6f3479.tar.gz
Initial import 0.2.0
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--correct_image_path.patch12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ff7eba483d2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Wed Feb 13 17:32:57 UTC 2019
+pkgbase = python-nestle-doc
+ pkgdesc = Documentation for Nestle
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = http://kylebarbary.com/nestle/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = python-nestle=0.2.0
+ makedepends = python-sphinx-gallery
+ makedepends = python-corner
+ makedepends = python-scipy
+ source = https://github.com/kbarbary/nestle/archive/v0.2.0.tar.gz
+ source = correct_image_path.patch
+ md5sums = 64edb99c551804d6847278a39d0ee183
+ md5sums = ad877ac724bb6f66415b7e66f055238d
+
+pkgname = python-nestle-doc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6214923cb256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Astro Benzene <universebenzene at sina dot com>
+_pyname=nestle
+pkgname=python-${_pyname}-doc
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Documentation for Nestle"
+arch=('i686' 'x86_64')
+url="http://kylebarbary.com/nestle/"
+license=('MIT')
+makedepends=("python-${_pyname}=${pkgver}" 'python-sphinx-gallery' 'python-corner' 'python-scipy')
+source=("https://github.com/kbarbary/nestle/archive/v${pkgver}.tar.gz"
+ 'correct_image_path.patch')
+md5sums=('64edb99c551804d6847278a39d0ee183'
+ 'ad877ac724bb6f66415b7e66f055238d')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ patch -Np1 -i "${srcdir}/correct_image_path.patch"
+}
+
+build() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs
+
+ make html
+}
+
+package() {
+ cd ${srcdir}/${_pyname}-${pkgver}/docs/_build
+
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+ cp -a html "${pkgdir}/usr/share/doc/${pkgname%-doc}"
+}
diff --git a/correct_image_path.patch b/correct_image_path.patch
new file mode 100644
index 000000000000..a1cc198d332d
--- /dev/null
+++ b/correct_image_path.patch
@@ -0,0 +1,12 @@
+diff -ura a/docs/index.rst b/docs/index.rst
+--- a/docs/index.rst 2019-02-13 23:42:16.297754478 +0800
++++ b/docs/index.rst 2019-02-13 23:42:36.481931189 +0800
+@@ -4,7 +4,7 @@
+
+ /ˈnesəl/ *(rhymes with "wrestle")*
+
+-.. image:: _images/sphx_glr_plot_ellipsoids_001.png
++.. image:: /examples/images/sphx_glr_plot_ellipsoids_001.png
+ :width: 280px
+ :align: right
+ :target: examples/plot_ellipsoids.html