summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2017-01-06 22:24:46 +0200
committerSpyros Stathopoulos2017-01-06 22:24:46 +0200
commit6d06806b12f5685215731f473845cfb922a95176 (patch)
tree6b92ea1ec0010bb250a39d7f6a6adb9c21456c4d
parent348bf26be8b4f4213387152e85d0c33f3afb4549 (diff)
downloadaur-6d06806b12f5685215731f473845cfb922a95176.tar.gz
Update 1.2.6 with recent git commits
As the tests seem to fail with Python 3.6 and there is not a way to cleanly apply the patches to 1.2.6 as is bring the package up to a speed to a recent git prerelease commit.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
-rw-r--r--git6350c32.diff.xzbin0 -> 96096 bytes
3 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ae8e7f30740..61015e6e6ffc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,26 @@
# Generated by mksrcinfo v8
-# Sun Dec 25 16:05:58 UTC 2016
+# Fri Jan 6 20:22:15 UTC 2017
pkgbase = python-netcdf4
pkgdesc = A python3 library for reading, manpiulating and creating netcdf files
- pkgver = 1.2.6
- pkgrel = 3
+ pkgver = 1.2.7pre
+ pkgrel = 1
url = https://unidata.github.io/netcdf4-python/
arch = x86_64
arch = i686
license = MIT
makedepends = cython
- depends = python
+ makedepends = xz
+ depends = python<=3.6.99
+ depends = python>3.5.99
depends = python-numpy
depends = netcdf>=4.1.2
depends = hdf5
optdepends = python2-netcdf4: python 2 version, includes docs and examples
optdepends = curl: for OPeNDAP suport
source = https://github.com/Unidata/netcdf4-python/archive/v1.2.6rel.tar.gz
+ source = git6350c32.diff.xz
md5sums = 2f131c845b279d233105b226bc632798
+ md5sums = 9f4c3c98762c9d5bf5d7a9fef0a526cb
pkgname = python-netcdf4
diff --git a/PKGBUILD b/PKGBUILD
index e505252a8277..0b5401725e2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,44 @@
# Contributor: rememberthemer <rememberthemer@_GMAIL_DOT_COM_>
pkgname=python-netcdf4
-pkgver=1.2.6
-pkgrel=3
+pkgver=1.2.7pre
+_pkgver=1.2.6
+pkgrel=1
pkgdesc="A python3 library for reading, manpiulating and creating netcdf files"
arch=('x86_64' 'i686')
url="https://unidata.github.io/netcdf4-python/"
license=('MIT')
-depends=('python' 'python-numpy' 'netcdf>=4.1.2' 'hdf5')
+depends=('python<=3.6.99' 'python>3.5.99' 'python-numpy' 'netcdf>=4.1.2' 'hdf5')
-makedepends=('cython')
+makedepends=('cython' 'xz')
optdepends=('python2-netcdf4: python 2 version, includes docs and examples'
'curl: for OPeNDAP suport')
-source=(https://github.com/Unidata/netcdf4-python/archive/v${pkgver}rel.tar.gz)
-md5sums=('2f131c845b279d233105b226bc632798')
+source=("https://github.com/Unidata/netcdf4-python/archive/v${_pkgver}rel.tar.gz"
+ "git6350c32.diff.xz")
+md5sums=('2f131c845b279d233105b226bc632798'
+ '9f4c3c98762c9d5bf5d7a9fef0a526cb')
+
+prepare() {
+ cd "$srcdir"/netcdf4-python-${_pkgver}rel
+ patch -p1 < ../'git6350c32.diff'
+}
build() {
- cd "$srcdir"/netcdf4-python-${pkgver}rel
+ cd "$srcdir"/netcdf4-python-${_pkgver}rel
2to3 -vnw setup.py
USE_NCCONFIG=1 python setup.py clean --all
USE_NCCONFIG=1 python setup.py build
}
check() {
- cd "${srcdir}"/netcdf4-python-${pkgver}rel
+ cd "${srcdir}"/netcdf4-python-${_pkgver}rel
cd "test"
- NO_NET=1 PYTHONPATH="../build/lib.linux-${CARCH}-3.5" python -B ./run_all.py
+ NO_NET=1 PYTHONPATH="../build/lib.linux-${CARCH}-3.6" python -B ./run_all.py
}
package() {
- cd "$srcdir"/netcdf4-python-${pkgver}rel
+ cd "$srcdir"/netcdf4-python-${_pkgver}rel
USE_NCCONFIG=1 python setup.py install --prefix=/usr \
--root="$pkgdir" --skip-build --optimize 2
diff --git a/git6350c32.diff.xz b/git6350c32.diff.xz
new file mode 100644
index 000000000000..2f085a77c653
--- /dev/null
+++ b/git6350c32.diff.xz
Binary files differ