summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Wojdyla2021-10-25 23:09:07 +0200
committerMichal Wojdyla2021-10-25 23:09:07 +0200
commitb3cf6ff64d3d862975a26b65c890bb0bc8ce7698 (patch)
tree541033c89817f0a0776433751c4ed8c8fc149798
parent26c9d0cd01c3381a64620909839983c3dc7de161 (diff)
downloadaur-python-netifaces-git.tar.gz
change repo
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 26 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e95d4bb5684..6621fbad1eb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-netifaces-git
- pkgdesc = Portable module to access network interface information in Python 3
- pkgver = 1.0.0.r6.098dfda
+ pkgdesc = Portable module to access network interface information in Python
+ pkgver = 0.11.0.r127.53fcdb6
pkgrel = 1
- url = https://github.com/kelleyk/py3k-netifaces
- arch = i686
+ epoch = 1
+ url = https://alastairs-place.net/netifaces/
arch = x86_64
license = MIT
makedepends = git
- makedepends = python-distribute
+ makedepends = python-setuptools
depends = python
- source = python-netifaces-git::git://github.com/kelleyk/py3k-netifaces.git
+ provides = python-netifaces
+ conflicts = python-netifaces
+ source = python-netifaces-git::git+https://github.com/al45tair/netifaces
sha256sums = SKIP
pkgname = python-netifaces-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 47af42280d15..e183152da503 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,35 @@
-# Maintainer: sudokode <sudokode@gmail.com>
+# Contributor: sudokode <sudokode@gmail.com>
pkgname=python-netifaces-git
-pkgver=1.0.0.r6.098dfda
+epoch=1
+pkgver=0.11.0.r127.53fcdb6
pkgrel=1
-pkgdesc="Portable module to access network interface information in Python 3"
-arch=('i686' 'x86_64')
-url="https://github.com/kelleyk/py3k-netifaces"
+pkgdesc="Portable module to access network interface information in Python"
+arch=('x86_64')
+url="https://alastairs-place.net/netifaces/"
license=('MIT')
+provides=('python-netifaces')
+conflicts=('python-netifaces')
depends=('python')
-makedepends=('git' 'python-distribute')
-source=("$pkgname::git://github.com/kelleyk/py3k-netifaces.git")
+makedepends=('git' 'python-setuptools')
+source=("$pkgname::git+https://github.com/al45tair/netifaces")
sha256sums=('SKIP')
pkgver() {
cd $pkgname
+ echo "0.11.0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
- echo "1.0.0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+build() {
+ cd $pkgname
+ python setup.py build
}
package() {
cd $pkgname
- python setup.py install --root "$pkgdir"
+ python setup.py install --root "${pkgdir}" --skip-build
- install -Dm644 README "$pkgdir"/usr/share/python-netifaces/README
- install -Dm644 README "$pkgdir"/usr/share/licenses/python-netifaces/LICENSE
+ # Install license, that is inside the readme file
+ install -Dm644 README.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-# vim:set ts=2 sw=2 et: