summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Bocken2023-11-21 20:53:24 +0100
committerAlexander Bocken2023-11-21 20:53:24 +0100
commit97f4e0631f6150e9342e7258ba3e4a2ec0e0d633 (patch)
treeba49907acb53d9acb7c8e1d89dfabb25a29f440c
downloadaur-97f4e0631f6150e9342e7258ba3e4a2ec0e0d633.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2026ffe0d41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-neurokit2
+ pkgdesc = The Python Toolbox for Neurophysiological Signal Processing.
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://github.com/scientisst/BioSPPy
+ arch = any
+ license = MIT
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python>=3.9
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-pandas
+ depends = python-matplotlib
+ depends = python-scikit-learn>=1.0.0
+ noextract = neurokit2-0.2.7-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/n/neurokit2/neurokit2-0.2.7-py2.py3-none-any.whl
+ sha256sums = 960412136d42ec02eca21b20de2f4ba2bce1d9eeabb34153b2e962682ff2ca42
+
+pkgname = python-neurokit2
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5769cda725c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Alexander Bocken <alexander@bocken.org>
+
+_name=neurokit2
+pkgname=python-${_name,,}
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="The Python Toolbox for Neurophysiological Signal Processing."
+arch=('any')
+url="https://github.com/scientisst/BioSPPy"
+license=('MIT')
+depends=('python>=3.9'
+ 'python-numpy'
+ 'python-scipy'
+ 'python-pandas'
+ 'python-matplotlib'
+ 'python-scikit-learn>=1.0.0'
+)
+makedepends=('python-installer' 'python-wheel')
+
+_whl="${_name//-/_}-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/${_name//-/_}-$pkgver-py2.py3-none-any.whl")
+sha256sums=('960412136d42ec02eca21b20de2f4ba2bce1d9eeabb34153b2e962682ff2ca42')
+
+noextract=("$_whl")
+package() {
+ _python_version="$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+ python -m installer --destdir="$pkgdir" "$_whl"
+ _license_path="${pkgdir}/usr/lib/python${_python_version}/site-packages/${_name}-${pkgver}.dist-info/LICENSE"
+ install -Dm644 "${_license_path}" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ rm -rf "${pkgdir}/usr/lib/python${_python_version}/site-packages/tests"
+}