summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-08-24 01:07:12 -0700
committerAaron DeVore2015-08-24 01:11:09 -0700
commit1a423f07707b850230722e77e5e89be38b529fc5 (patch)
tree09907a172ce55cbadd9a5f8932dddb749a893227
parent4ae90b8139adb7aecca1a7829b32dc0850d5a45e (diff)
downloadaur-python-nevow.tar.gz
Version bump to 0.11.1-1, remove Changelog, update to current standards & dependencies
-rw-r--r--.SRCINFO17
-rw-r--r--Changelog4
-rw-r--r--PKGBUILD26
3 files changed, 16 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e933c7fbb88..e66478c761ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-nevow
pkgdesc = Web application construction kit and templating engine written in python.
- pkgver = 0.10.0
- pkgrel = 3
- url = http://divmod.org/trac/wiki/DivmodNevow
- changelog = Changelog
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/twisted/nevow
arch = any
license = custom
- makedepends = twisted
- makedepends = python2-distribute
+ makedepends = python2-twisted
+ makedepends = python2-setuptools
depends = python2
- optdepends = twisted: to use all the advanced features of nevow, such as LivePage
+ optdepends = python2-twisted: to use all the advanced features of nevow, such as LivePage
options = !emptydirs
- source = http://pypi.python.org/packages/source/N/Nevow/Nevow-0.10.0.tar.gz
- md5sums = 66dda2ad88f42dea05911add15f4d1b2
+ source = http://pypi.python.org/packages/source/N/Nevow/Nevow-0.11.1.tar.gz
+ md5sums = acc5d23bd94a5399752065baae6117f6
pkgname = python-nevow
diff --git a/Changelog b/Changelog
deleted file mode 100644
index 6718c168ecf3..000000000000
--- a/Changelog
+++ /dev/null
@@ -1,4 +0,0 @@
-2011-10-23 Aaron DeVore <aaron.devore@gmail.com>
-- Switch from dead divmod link to Python Package Index
-- Cosmetic clean ups
-- Switch from setuptools to python2-distribute
diff --git a/PKGBUILD b/PKGBUILD
index 788b2eb524c5..a4dd18f386a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,20 @@
# Contributor: Marco Elver <el.marcoe+arch at gmail dot com>
pkgname=python-nevow
-pkgver=0.10.0
-pkgrel=3
+pkgver=0.11.1
+pkgrel=1
arch=(any)
license=('custom')
pkgdesc="Web application construction kit and templating engine written in python."
-url="http://divmod.org/trac/wiki/DivmodNevow"
+url="https://github.com/twisted/nevow"
depends=('python2')
-optdepends=('twisted: to use all the advanced features of nevow, such as LivePage')
-makedepends=('twisted' 'python2-distribute')
+optdepends=('python2-twisted: to use all the advanced features of nevow, such as LivePage')
+makedepends=('python2-twisted' 'python2-setuptools')
source=("http://pypi.python.org/packages/source/N/Nevow/Nevow-${pkgver}.tar.gz")
-md5sums=('66dda2ad88f42dea05911add15f4d1b2')
+md5sums=('acc5d23bd94a5399752065baae6117f6')
options=(!emptydirs)
-changelog=Changelog
-build() {
+package() {
cd $srcdir/Nevow-$pkgver
python2 setup.py install --root=$pkgdir --optimize=1
@@ -25,17 +24,8 @@ build() {
mv $pkgdir/usr/doc/man $pkgdir/usr/share/
mv $pkgdir/usr/doc/* $pkgdir/usr/share/doc/nevow/
rm -r $pkgdir/usr/doc
-
- # Same as above - in v0.9.33 nevow_widget.py was in the right
- # place. Can anybody explain why this has changed? Let's hope this
- # gets fixed in their next setup.py.
- _python_version=`python2 -c "import sys; print sys.version[:3]"`
- _python_twisted_plugins="$pkgdir/usr/lib/python${_python_version}/site-packages/twisted/plugins/"
- mkdir -p $_python_twisted_plugins
- mv $pkgdir/usr/twisted/plugins/nevow_widget.py $_python_twisted_plugins
- rm -r $pkgdir/usr/twisted
- # Distribute doesn't kill off #!/usr/bin/python shebangs
+ # Setuptools doesn't kill off #!/usr/bin/python shebangs
find $pkgdir -name "*.py" -exec \
sed -i '1s/python[[:space:]]*$/python2/' {} \;