summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Whitfield2016-07-19 16:47:20 -0400
committerRoss Whitfield2016-07-19 16:47:20 -0400
commit2f740fe6af57a38b56a19c3c2d81208ece5aa735 (patch)
tree1f97ef9bef210e2592766c408c207d4b8a629afd
downloadaur-2f740fe6af57a38b56a19c3c2d81208ece5aa735.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD30
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..768d53d1e48f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = python-nexpy
+ pkgdesc = NeXpy: A Python GUI to analyze NeXus data
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = http://nexpy.github.io/nexpy
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = python-six
+ makedepends = python2-six
+ source = https://github.com/nexpy/nexpy/archive/v0.8.1.tar.gz
+ md5sums = 04eccf4f06eb1532cc76fb631a96af79
+
+pkgname = python-nexpy
+ depends = python-numpy
+ depends = python-h5py
+ depends = python-scipy
+ depends = python-nexusformat
+ depends = jupyter
+ depends = python-matplotlib
+
+pkgname = python2-nexpy
+ depends = python2-numpy
+ depends = python2-h5py
+ depends = python2-scipy
+ depends = python2-nexusformat
+ depends = ipython2-notebook
+ depends = python2-matplotlib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f6b5fc4c27e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ross Whitfield <whitfieldre@ornl.gov>
+pkgname=('python-nexpy' 'python2-nexpy')
+_pkgname=nexpy
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="NeXpy: A Python GUI to analyze NeXus data"
+url="http://nexpy.github.io/nexpy"
+arch=("any")
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-six' 'python2-six')
+source=("https://github.com/nexpy/nexpy/archive/v${pkgver}.tar.gz")
+md5sums=('04eccf4f06eb1532cc76fb631a96af79')
+
+prepare() {
+ cp -a "${srcdir}/$_pkgname-$pkgver"{,-py2}
+}
+
+package_python-nexpy() {
+ depends=('python-numpy' 'python-h5py' 'python-scipy' 'python-nexusformat' 'jupyter' 'python-matplotlib')
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-nexpy() {
+ depends=('python2-numpy' 'python2-h5py' 'python2-scipy' 'python2-nexusformat' 'ipython2-notebook' 'python2-matplotlib')
+ cd "$srcdir/$_pkgname-$pkgver-py2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ # Conflict with python3 version
+ mv $pkgdir/usr/bin/nexpy{,2}
+}