summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Whitfield2016-07-19 18:26:07 -0400
committerRoss Whitfield2016-07-19 18:26:07 -0400
commitdf30403d4c98e7429e87eaa4c7399b5375b15fb4 (patch)
tree17be8ca3840f906f82c9beaad43a702481dab694
parent2f740fe6af57a38b56a19c3c2d81208ece5aa735 (diff)
downloadaur-df30403d4c98e7429e87eaa4c7399b5375b15fb4.tar.gz
Fix can't fin jupyter at runtime
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2f6b5fc4c27e..9dfb2b6e8164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,12 +18,14 @@ prepare() {
package_python-nexpy() {
depends=('python-numpy' 'python-h5py' 'python-scipy' 'python-nexusformat' 'jupyter' 'python-matplotlib')
cd "$srcdir/$_pkgname-$pkgver"
+ sed -i 's/jupyter/jupyter_core/' src/nexpy/requires.py # Can't find jupyter at run time
python setup.py install --root="$pkgdir/" --optimize=1
}
package_python2-nexpy() {
depends=('python2-numpy' 'python2-h5py' 'python2-scipy' 'python2-nexusformat' 'ipython2-notebook' 'python2-matplotlib')
cd "$srcdir/$_pkgname-$pkgver-py2"
+ sed -i 's/jupyter/jupyter_core/' src/nexpy/requires.py # Can't find jupyter at run time
python2 setup.py install --root="$pkgdir/" --optimize=1
# Conflict with python3 version
mv $pkgdir/usr/bin/nexpy{,2}