summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Whitfield2016-07-19 16:33:28 -0400
committerRoss Whitfield2016-07-19 16:33:28 -0400
commitd1c3d5ba2ac1dcdb49c44f1f34ad14a42bc60f4c (patch)
tree94ca219340e709b853325dffde37e422e0659de8
downloadaur-d1c3d5ba2ac1dcdb49c44f1f34ad14a42bc60f4c.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8232b8a84376
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-nexusformat
+ pkgdesc = Provides an API to open, create, and manipulate NeXus data.
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/nexpy/nexusformat
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://github.com/nexpy/nexusformat/archive/v0.4.1.tar.gz
+ md5sums = 611a4247fde776f65aef4d844199d6cc
+
+pkgname = python-nexusformat
+ depends = python-numpy
+ depends = python-h5py
+
+pkgname = python2-nexusformat
+ depends = python2-numpy
+ depends = python2-h5py
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..091915401333
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Ross Whitfield <whitfieldre@ornl.gov>
+pkgname=('python-nexusformat' 'python2-nexusformat')
+_pkgname=nexusformat
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Provides an API to open, create, and manipulate NeXus data."
+url="https://github.com/nexpy/nexusformat"
+arch=("any")
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("https://github.com/nexpy/nexusformat/archive/v${pkgver}.tar.gz")
+md5sums=('611a4247fde776f65aef4d844199d6cc')
+
+prepare() {
+ cp -a "${srcdir}/$_pkgname-$pkgver"{,-py2}
+}
+
+package_python-nexusformat() {
+ depends=('python-numpy' 'python-h5py')
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-nexusformat() {
+ depends=('python2-numpy' 'python2-h5py')
+ cd "$srcdir/$_pkgname-$pkgver-py2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ # Conflict with python3 version
+ mv $pkgdir/usr/bin/nxstack{,2}
+}