summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYangtse Su2022-01-15 21:13:42 +0800
committerYangtse Su2022-01-15 21:13:42 +0800
commitd94e87a75f89aac7f1bdd3d82e1624a642186958 (patch)
tree02ad2d992ce068aa26283dff0d4ab6ac0c004896
downloadaur-d94e87a75f89aac7f1bdd3d82e1624a642186958.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..46aa685b2521
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-nfcpy-git
+ pkgdesc = Module to read/write NFC tags or communicate with another NFC device
+ pkgver = 1.0.3.r19.gacc6d32
+ pkgrel = 1
+ url = https://github.com/nfcpy/nfcpy
+ arch = x86_64
+ license = custom:EUPL
+ makedepends = python-setuptools
+ depends = python-libusb1
+ depends = python-pyserial
+ depends = python-ndeflib
+ depends = python-pydes
+ provides = python-nfcpy
+ conflicts = python-nfcpy
+ source = nfcpy::git+https://github.com/nfcpy/nfcpy
+ sha256sums = SKIP
+
+pkgname = python-nfcpy-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35100014d64f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Yangtse Su <yangtsesu@gmail.com>
+# Contributor: Iyán Méndez Veiga <me (at) iyanmv (dot) com>
+
+_pkgname=nfcpy
+pkgname=python-${_pkgname}-git
+pkgver=1.0.3.r19.gacc6d32
+pkgrel=1
+pkgdesc="Module to read/write NFC tags or communicate with another NFC device"
+arch=('x86_64')
+url="https://github.com/nfcpy/nfcpy"
+license=('custom:EUPL')
+depends=(
+ 'python-libusb1'
+ 'python-pyserial'
+ 'python-ndeflib'
+ 'python-pydes'
+)
+makedepends=('python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${_pkgname}::git+https://github.com/${_pkgname}/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}