summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-03 17:41:38 -0500
committerGuillaume Horel2017-03-03 17:45:47 -0500
commit464436f6e5a102919294dad383c6f30c393f22f8 (patch)
tree18d246aa97da3d87abc8a9f035c2d148803eeddd
downloadaur-464436f6e5a102919294dad383c6f30c393f22f8.tar.gz
initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37acaf6a680c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-ng-numpy-randomstate
+ pkgdesc = Numpy compatible random number generators.
+ pkgver = 1.12
+ pkgrel = 1
+ url = https://bashtage.github.io/ng-numpy-randomstate
+ arch = i686
+ arch = x86_64
+ license = custom:University of Illinois/NCSA Open Source License
+ makedepends = cython
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ source = https://github.com/bashtage/ng-numpy-randomstate/archive/1.12.tar.gz
+ sha256sums = f814c1263e663c018c414b8d50943db0
+
+pkgname = python-ng-numpy-randomstate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b97208a7635e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-ng-numpy-randomstate')
+_module='ng-numpy-randomstate'
+pkgver='1.12'
+pkgrel=1
+pkgdesc="Numpy compatible random number generators."
+url="https://bashtage.github.io/ng-numpy-randomstate"
+depends=('python' 'python-numpy')
+makedepends=(
+ 'cython'
+ 'python-setuptools')
+license=('custom:University of Illinois/NCSA Open Source License')
+arch=('i686' 'x86_64')
+source=("https://github.com/bashtage/ng-numpy-randomstate/archive/${pkgver}.tar.gz")
+sha256sums=('f814c1263e663c018c414b8d50943db0')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}