summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-31 02:17:26 -0200
committerandalenavals2017-10-31 02:17:26 -0200
commit2cfae87baa0379c9a97ce3be7f600d46aa7d0812 (patch)
treede6d0664b10e1933245d28a7293614b0fd775eb9
downloadaur-2cfae87baa0379c9a97ce3be7f600d46aa7d0812.tar.gz
Complete first release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12bf708a02db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-ngmix
+ pkgdesc = Python interface to gbdes pixel map (astrometry) solutions
+ pkgver = r1087.3a0e7ce
+ pkgrel = 1
+ url = https://github.com/esheldon/ngmix
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ source = python-ngmix-r1087.3a0e7ce::git+https://github.com/esheldon/ngmix
+ md5sums = SKIP
+
+pkgname = python-ngmix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e375ca7e2aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: M. Jarvis
+pkgname=python-ngmix
+pkgver=r1087.3a0e7ce
+pkgrel=1
+#epoch=
+
+pkgdesc=" Python interface to gbdes pixel map (astrometry) solutions "
+
+
+arch=('x86_64')
+url="https://github.com/esheldon/ngmix"
+license=('GPL')
+groups=()
+depends=('python' 'python-numpy')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python setup.py install --root=${pkgdir} --prefix=/usr
+
+}