summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-08-24 16:31:09 -0500
committerLuis Martinez2022-08-24 16:31:09 -0500
commitd0f294497d87fd2ffed797f8c51dbeac14749801 (patch)
tree6a56d0cb9fd37a336c65f675b1713da3a1544e33
parenta84721a9e6f9f15c4f6d23f7dfc91f6e3c9b7bce (diff)
downloadaur-d0f294497d87fd2ffed797f8c51dbeac14749801.tar.gz
update to 2.2.0
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGES.md8
-rw-r--r--PKGBUILD9
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b451dd711de..77c912ed6ed7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-ngmix
pkgdesc = Gaussian mixtures and image processing
- pkgver = 2.1.0
- pkgrel = 2
+ pkgver = 2.2.0
+ pkgrel = 1
url = https://github.com/esheldon/ngmix
changelog = CHANGES.md
arch = any
@@ -15,9 +15,9 @@ pkgbase = python-ngmix
optdepends = python-galsim: for metacalibration operations
optdepends = python-scikit-learn: for sampling multivariate PDFs
optdepends = python-scipy: for image fitting using Levenberg-Marquardt fitter
- source = python-ngmix-2.1.0.tar.gz::https://github.com/esheldon/ngmix/archive/v2.1.0.tar.gz
+ source = python-ngmix-2.2.0.tar.gz::https://github.com/esheldon/ngmix/archive/v2.2.0.tar.gz
source = setup.py.patch
- sha256sums = 5bda6377f6ecf41b9301cde0e62e55e990292c7825ffba6d5b2a0d3adcbbd50e
+ sha256sums = a499f5b0ae5888f50fb97e8b59107d529f296b7a0047129f629aa4e99ef7df06
sha256sums = 85057d5ec4f082a3599084dbe0e874be2af2a0f91786a10933b3368e6e025898
pkgname = python-ngmix
diff --git a/CHANGES.md b/CHANGES.md
index 3194e3a72a69..29456b82c039 100644
--- a/CHANGES.md
+++ b/CHANGES.md
@@ -1,3 +1,11 @@
+## v2.2.0
+
+### new features
+
+ - Added function to regularize moments results.
+ - Added numba to pre-PSF moments to reduce runtime.
+
+
## v2.1.0
### bug fixes
diff --git a/PKGBUILD b/PKGBUILD
index 2cd84617867c..dac645ffa95d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
pkgname=python-ngmix
_pkg="${pkgname#python-}"
-pkgver=2.1.0
-pkgrel=2
+pkgver=2.2.0
+pkgrel=1
pkgdesc='Gaussian mixtures and image processing'
arch=('any')
url="https://github.com/esheldon/ngmix"
@@ -16,11 +16,11 @@ optdepends=(
'python-scikit-learn: for sampling multivariate PDFs'
'python-scipy: for image fitting using Levenberg-Marquardt fitter')
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-# checkdepends=('python-pytest')
+# checkdepends=('python-pytest' 'python-galsim' 'python-scikit-learn' 'python-scipy')
changelog=CHANGES.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
'setup.py.patch')
-sha256sums=('5bda6377f6ecf41b9301cde0e62e55e990292c7825ffba6d5b2a0d3adcbbd50e'
+sha256sums=('a499f5b0ae5888f50fb97e8b59107d529f296b7a0047129f629aa4e99ef7df06'
'85057d5ec4f082a3599084dbe0e874be2af2a0f91786a10933b3368e6e025898')
prepare() {
@@ -33,7 +33,6 @@ build() {
python -m build --wheel --no-isolation
}
-## FIXME: optdepends required
# check() {
# cd "$_pkg-$pkgver"
# pytest -x