summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2018-07-16 22:59:22 -0300
committerandalenavals2018-07-16 22:59:22 -0300
commitdeb0f586286300957ae48753f3caf93b359e39f8 (patch)
tree67ab2412be24a091a9f5dd781d983399bf8f5872
parent2cfae87baa0379c9a97ce3be7f600d46aa7d0812 (diff)
downloadaur-deb0f586286300957ae48753f3caf93b359e39f8.tar.gz
this version have tests defined in comparions with git version
-rw-r--r--.SRCINFO17
-rwxr-xr-x[-rw-r--r--]PKGBUILD77
2 files changed, 51 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12bf708a02db..ef6c1dabc6ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,22 @@
pkgbase = python-ngmix
- pkgdesc = Python interface to gbdes pixel map (astrometry) solutions
- pkgver = r1087.3a0e7ce
+ pkgdesc = Gaussian mixture models and other code for working with for 2d images, implemented in python
+ pkgver = v0.9.4.r0.28e501c
pkgrel = 1
url = https://github.com/esheldon/ngmix
arch = x86_64
license = GPL
+ checkdepends = make
makedepends = git
- depends = python
- depends = python-numpy
- source = python-ngmix-r1087.3a0e7ce::git+https://github.com/esheldon/ngmix
+ makedepends = python
+ makedepends = python-numpy
+ makedepends = python2
+ makedepends = python2-numpy
+ source = python-ngmix::git+https://github.com/esheldon/ngmix#tag=v0.9.4
md5sums = SKIP
pkgname = python-ngmix
+ depends = python
+
+pkgname = python2-ngmix
+ depends = python2
diff --git a/PKGBUILD b/PKGBUILD
index 7e375ca7e2aa..f09a084e7d45 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,56 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
-# Contributor: M. Jarvis
-pkgname=python-ngmix
-pkgver=r1087.3a0e7ce
+# Contributor: Erin Sheldon
+_pkgname=python-ngmix
+pkgbase=python-ngmix
+pkgname=("python-ngmix" "python2-ngmix")
+pkgver=v0.9.4.r0.28e501c
pkgrel=1
-#epoch=
-
-pkgdesc=" Python interface to gbdes pixel map (astrometry) solutions "
-
-
+pkgdesc=" Gaussian mixture models and other code for working with for 2d images, implemented in python "
arch=('x86_64')
url="https://github.com/esheldon/ngmix"
license=('GPL')
-groups=()
-depends=('python' 'python-numpy')
-makedepends=('git')
-checkdepends=()
-optdepends=()
-#provides=()
-#conflicts=()
-#replaces=()
-#backup=()
-options=()
-install=
-changelog=
-source=("$pkgname-$pkgver::git+${url}")
-#noextract=()
+checkdepends=('make')
+makedepends=('git' 'python' 'python-numpy' 'python2' 'python2-numpy' )
+source=("${_pkgname}::git+${url}#tag=v0.9.4")
md5sums=('SKIP')
-#validpgpkeys=()
+pkgver() {
+ cd $_pkgname
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cp -a $_pkgname{,-py2}
+}
build() {
- cd "$src"
- cd "$pkgname-$pkgver"
+ cd "$srcdir"/$_pkgname
python setup.py build
-}
+ cd "$srcdir"/$_pkgname-py2
+ python2 setup.py build
+}
-pkgver() {
- cd "$pkgname-$pkgver"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+check() {
+ cd "$srcdir"/$_pkgname/test
+ make test/test-gmix test/test-gmix-model test/test-fastexp test/test-fastexp-speed test/test-image test/test-shape
+ ./test/test-gmix
+ ./test/test-gmix-model
+ ./test/test-fastexp
+ ./test/test-fastexp-speed
+ ./test/test-image
+ ./test/test-shape
}
+package_python-ngmix() {
+ depends=('python')
+ cd "${_pkgname}"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+}
-package() {
- cd "$src"
- cd "$pkgname-$pkgver"
- python setup.py install --root=${pkgdir} --prefix=/usr
+package_python2-ngmix() {
+ depends=('python2')
+ cd "${_pkgname}"
+ python2 setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
}