summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-25 14:05:02 -0500
committerCarlos Aznarán Laos2022-10-25 14:05:02 -0500
commit629567023c9c4cceb30f6ac2866fbcf8e421c67d (patch)
tree2b71829a0cf8f908271eef24281a374cec1820ad
parent52bb2b0fc557037925d735b4648b19d63f5a64f6 (diff)
downloadaur-629567023c9c4cceb30f6ac2866fbcf8e421c67d.tar.gz
Change python-install by python-installer
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51580e4e2741..180c24be3e30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = python-niaaml
license = MIT
checkdepends = python-pytest
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-poetry-core
depends = python-niapy
depends = python-scikit-learn
diff --git a/PKGBUILD b/PKGBUILD
index f1516fd1235c..bcd82357ea9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="https://github.com/lukapecnik/${_base}"
arch=(any)
license=(MIT)
depends=(python-niapy python-scikit-learn)
-makedepends=(python-build python-install python-poetry-core)
+makedepends=(python-build python-installer python-poetry-core)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
sha512sums=('6513879a1843be932f271ad3a1d6bd92736a7d7c2e3dbd37c543f6c49563c10281ffeba2e2133dbb182cb68a68287a8bb61ba508a756ef094858ffb0c5e96aa9')
@@ -25,6 +25,6 @@ check() {
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}