summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Fishburn2018-03-09 13:41:38 -0500
committerFrank Fishburn2018-03-09 13:41:38 -0500
commit82280c58cdca22dcaba65f5065fe320cea82ad6a (patch)
tree2530d929ada0ad16b4df8094fb2124797504f43c
downloadaur-82280c58cdca22dcaba65f5065fe320cea82ad6a.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5d3d04a1786
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-nipype
+ pkgdesc = Neuroimaging in python pipelines and interfaces
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/prov/
+ arch = any
+ license = Apache
+ depends = python
+ depends = python-dbus
+ depends = python-numpy
+ depends = python-numpydoc
+ depends = python-pytest
+ optdepends = fsl
+ optdepends = afni
+ source = https://github.com/nipy/nipype/archive/1.0.1.tar.gz
+ sha256sums = b06d1504e27cfdca51dcf3b821223b5913f37d87a637a235a0e3bef1cff19951
+
+pkgname = python-nipype
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eeee8a6f2dfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Frank Fishburn <frankthefishburn@gmail.com>
+# Maintainer: Frank Fishburn <frankthefishburn@gmail.com>
+pkgname=python-nipype
+_name=${pkgname/python-/}
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Neuroimaging in python pipelines and interfaces'
+arch=('any')
+url='https://pypi.python.org/pypi/prov/'
+license=('Apache')
+depends=('python' 'python-dbus' 'python-numpy' 'python-numpydoc' 'python-pytest')
+optdepends=('fsl' 'afni')
+source=("https://github.com/nipy/${_name}/archive/${pkgver}.tar.gz")
+sha256sums=('b06d1504e27cfdca51dcf3b821223b5913f37d87a637a235a0e3bef1cff19951')
+
+build() {
+ cd ${srcdir}/${_name}-${pkgver}
+ make
+}
+
+package() {
+ cd $srcdir/${_name}-${pkgver}
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+