summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2023-08-24 12:35:42 +0200
committerMatheus2023-08-24 12:35:42 +0200
commit63c880d9a87c34b85bbc03406e0e81ddcded2e4f (patch)
tree7be21ea2f9afa53819086fa48ca97bb1599e60d9
parent84d8a87f996c68726b0cc42a351efc6767c124ad (diff)
downloadaur-63c880d9a87c34b85bbc03406e0e81ddcded2e4f.tar.gz
Update.
-rwxr-xr-x.SRCINFO9
-rwxr-xr-xPKGBUILD22
2 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdc3ec192c88..03adc294d106 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-nostalgiaforinfinity
pkgdesc = Trading strategy for the Freqtrade crypto bot.
- pkgver = 13.0.384
+ pkgver = 13.0.416
pkgrel = 1
url = https://github.com/iterativv/NostalgiaForInfinity
arch = any
license = GPL3
+ checkdepends = python-ast-comments
checkdepends = python-pytest
checkdepends = python-pytest-mock
+ checkdepends = python-pytest-pretty
checkdepends = python-pytest-subtests
+ checkdepends = python-pytest-xdist
makedepends = git
depends = bash
depends = python
@@ -18,9 +21,7 @@ pkgbase = python-nostalgiaforinfinity
depends = python-rapidjson
depends = python-ta-lib
depends = python-technical
- source = python-nostalgiaforinfinity::git+https://github.com/iterativv/NostalgiaForInfinity.git?#tag=929bbbc758989064258a4b58395524ec82ce1a53
- source = git+https://github.com/iterativv/NostalgiaForInfinityData
- sha512sums = SKIP
+ source = python-nostalgiaforinfinity::git+https://github.com/iterativv/NostalgiaForInfinity.git?#tag=3d09bb20a37c930d6005512dfbe7ab5b3b398196
sha512sums = SKIP
pkgname = python-nostalgiaforinfinity
diff --git a/PKGBUILD b/PKGBUILD
index 869011a0ff08..c444998798e7 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@
# Contributor: Matheus <matheusgwdl@protonmail.com>
readonly _pkgname="NostalgiaForInfinity"
-declare -r _tag="929bbbc758989064258a4b58395524ec82ce1a53"
+declare -r _tag="3d09bb20a37c930d6005512dfbe7ab5b3b398196"
pkgname="python-nostalgiaforinfinity"
-pkgver="13.0.384"
+pkgver="13.0.416"
pkgrel="1"
pkgdesc="Trading strategy for the Freqtrade crypto bot."
arch=("any")
@@ -17,21 +17,9 @@ url="https://github.com/iterativv/${_pkgname}"
license=("GPL3")
depends=("bash" "python" "python-freqtrade" "python-numpy" "python-pandas" "python-pandas-ta" "python-rapidjson" "python-ta-lib" "python-technical")
makedepends=("git")
-checkdepends=("python-pytest" "python-pytest-mock" "python-pytest-subtests")
-source=("${pkgname}::git+${url}.git?#tag=${_tag}"
- "git+https://github.com/iterativv/NostalgiaForInfinityData")
-sha512sums=("SKIP"
- "SKIP")
-
-prepare()
-{
- cd "${srcdir}"/"${pkgname}"/ || exit 1
- git submodule init
-
- git config submodule.user_data/data.url "${srcdir}"/NostalgiaForInfinityData/
-
- git -c protocol.file.allow=always submodule update
-}
+checkdepends=("python-ast-comments" "python-pytest" "python-pytest-mock" "python-pytest-pretty" "python-pytest-subtests" "python-pytest-xdist")
+source=("${pkgname}::git+${url}.git?#tag=${_tag}")
+sha512sums=("SKIP")
check()
{