summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuijie Yu2020-08-19 08:39:13 -0400
committerRuijie Yu2020-08-19 08:39:13 -0400
commite549cfe1b795fdae09d06abaa1f7ea31870cce2c (patch)
treed2632c4872091b93f4260b35d809c5eae94e7c33
downloadaur-e549cfe1b795fdae09d06abaa1f7ea31870cce2c.tar.gz
v1.3.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..203498711289
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-nptyping
+ pkgdesc = Type hints for Numpy.
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/ramonhagenaars/nptyping
+ arch = any
+ license = MIT
+ checkdepends = python-pycodestyle
+ checkdepends = python-pylint
+ checkdepends = python-pytest
+ checkdepends = python-coverage
+ makedepends = python-pip
+ depends = python>=3.5
+ depends = python-numpy
+ depends = python-typish>=1.5.2
+ source = https://github.com/ramonhagenaars/nptyping/archive/v1.3.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = python-nptyping
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be85ca170ef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer Ruijie Yu (first.last@outlook.com)
+
+pkgname=python-nptyping
+_pkgname="${pkgname#python-}"
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Type hints for Numpy.'
+url="https://github.com/ramonhagenaars/nptyping"
+arch=(any)
+license=(MIT)
+
+depends=(
+ 'python>=3.5'
+ 'python-numpy'
+ 'python-typish>=1.5.2'
+)
+
+makedepends=(
+ 'python-pip'
+ # 'python-wheel'
+)
+
+checkdepends=(
+ 'python-pycodestyle'
+ 'python-pylint'
+ 'python-pytest'
+ 'python-coverage'
+ # 'python-codecov'
+)
+
+source=(
+ 'https://github.com/ramonhagenaars/nptyping/archive/v1.3.0.tar.gz'
+)
+sha512sums=(
+ SKIP
+)
+
+_extracted="$_pkgname-$pkgver/"
+
+check() {
+ ## how do we "test" with python/pip?
+ ## `./setup.py test` seems to be deprecated
+
+ # python "$srcdir/$_extracted/setup.py" test
+ :
+}
+
+package() {
+ pip install --no-deps --root "${pkgdir}" --compile "$srcdir/$_extracted"
+}
+