summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2018-10-01 19:08:56 +0200
committerChristopher Arndt2018-10-01 19:08:56 +0200
commitfd03249864239b9eafd131dae225a41a793a8fd1 (patch)
tree267d5199fe6909c217255d192fbcafe7037f1f67
downloadaur-fd03249864239b9eafd131dae225a41a793a8fd1.tar.gz
Add new package 'python-nudatus'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31899730abf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-nudatus
+ pkgdesc = A tool to remove comments from Python scripts
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/zanderbrown/nudatus
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/n/nudatus/nudatus-0.0.3.tar.gz
+ sha256sums = ca2324777a10df8593eacacdd37a00e8fc780d5dc6a78cb02d6e6a5a85337ac9
+
+pkgname = python-nudatus
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..95d9fc654918
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+nudatus-*.tar.gz
+python-nudatus-*.pkg.tar.xz
+.AURINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eff3ef20ff2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+pkgname='python-nudatus'
+_module='nudatus'
+pkgver='0.0.3'
+pkgrel=1
+pkgdesc="A tool to remove comments from Python scripts"
+url="https://github.com/zanderbrown/nudatus"
+depends=('python')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/n/${_module}/${_module}-${pkgver}.tar.gz")
+sha256sums=('ca2324777a10df8593eacacdd37a00e8fc780d5dc6a78cb02d6e6a5a85337ac9')
+
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}