summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2017-07-31 13:28:51 -0400
committerBuildTools2017-07-31 13:28:51 -0400
commit385249fb6a783e349e59924112366361a8557838 (patch)
tree726e85e6157088212d5e4854b653c8113fc015bf
downloadaur-385249fb6a783e349e59924112366361a8557838.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33f2fa11be3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-num2words
+ pkgdesc = Python modules to convert numbers to words.
+ pkgver = 0.5.5
+ pkgrel = 1
+ url = https://github.com/savoirfairelinux/num2words
+ arch = any
+ license = LGPL
+ checkdepends = python
+ checkdepends = python2
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://github.com/savoirfairelinux/num2words/archive/0.5.5.tar.gz
+ sha256sums = 8e234b7bdcf25c606969b4002d514808ec79c990859279f6cead261d9803f752
+
+pkgname = python-num2words
+ pkgdesc = Python modules to convert numbers to words. (python3 version)
+ depends = python
+
+pkgname = python2-num2words
+ pkgdesc = Python modules to convert numbers to words. (python2 version)
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..586445340359
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgbase=python-num2words
+pkgname=('python-num2words' 'python2-num2words')
+pkgver=0.5.5
+pkgrel=1
+pkgdesc="Python modules to convert numbers to words."
+arch=('any')
+url='https://github.com/savoirfairelinux/num2words'
+license=('LGPL')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python' 'python2')
+source=("https://github.com/savoirfairelinux/num2words/archive/${pkgver}.tar.gz")
+sha256sums=('8e234b7bdcf25c606969b4002d514808ec79c990859279f6cead261d9803f752')
+
+check() {
+ cd "${srcdir}/num2words-${pkgver}"
+ python setup.py test
+ python2 setup.py test
+}
+
+package_python-num2words() {
+ depends=('python')
+ pkgdesc="Python modules to convert numbers to words. (python3 version)"
+
+ cd "${srcdir}/num2words-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}
+
+package_python2-num2words() {
+ depends=('python2')
+ pkgdesc="Python modules to convert numbers to words. (python2 version)"
+
+ cd "${srcdir}/num2words-${pkgver}"
+ python2 setup.py install --root=${pkgdir}
+}
+
+# vim:set ts=2 sw=2 et: