summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchrisjbillington2019-11-19 20:26:42 -0500
committerchrisjbillington2019-11-19 20:26:42 -0500
commitf6ae9fefbd9fd0174acb79af22e24f980b59ee84 (patch)
tree2ebaf424b2bc650da6bfb92f41ff22a9ac4bf27f
downloadaur-f6ae9fefbd9fd0174acb79af22e24f980b59ee84.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cc8aaf7e718
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-numexpr-mkl-bin
+ pkgdesc = Fast numerical array expression evaluator for Python - with Intel MLK - prebuilt binaries from Anaconda
+ pkgver = 2.7.0.0.py38h9e4a6bb.0
+ pkgrel = 0
+ url = https://github.com/pydata/numexpr
+ arch = x86_64
+ license = MIT
+ depends = python-mkl-service
+ depends = python-numpy
+ provides = python-numexpr
+ conflicts = python-numexpr
+ source = https://repo.anaconda.com/pkgs/main/linux-64/numexpr-2.7.0-py38h9e4a6bb_0.tar.bz2
+ sha256sums = 2bbeaa19f443e53d251beb57c058f84a79960eba1271b072753c0eda6deca374
+
+pkgname = python-numexpr-mkl-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b4b0ee1e33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer : Chris Billington <chrisjbillington@gmail.com>
+pkgname=python-numexpr-mkl-bin
+_pkgname=numexpr
+_pkgver=2.7.0
+_build=py38h9e4a6bb_0
+_build_number=0
+pkgver="${_pkgver}.${_build_number}.${_build//_/.}"
+pkgrel=0
+pkgdesc="Fast numerical array expression evaluator for Python - with Intel MLK - prebuilt binaries from Anaconda"
+arch=('x86_64')
+url="https://github.com/pydata/numexpr"
+license=('MIT')
+provides=('python-numexpr')
+conflicts=('python-numexpr')
+depends=('python-mkl-service' 'python-numpy')
+source=("https://repo.anaconda.com/pkgs/main/linux-64/${_pkgname}-${_pkgver}-${_build}.tar.bz2")
+sha256sums=('2bbeaa19f443e53d251beb57c058f84a79960eba1271b072753c0eda6deca374')
+
+package() {
+ mkdir "${pkgdir}/usr"
+ cp -drp --no-preserve=ownership "${srcdir}/lib" "${pkgdir}/usr/lib"
+ install -D -m 644 "${srcdir}/info/licenses/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+} \ No newline at end of file