summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-05-04 11:46:12 +0200
committera8212023-05-04 11:46:12 +0200
commit56be3d1c6b9a38ce6001de7ce715fd64f7e0f61f (patch)
treeb4372e279458b69c46f248f4ce86cde26b2a909b
parentf8c2a536097dc3420afd94c3f1969116b60b17e6 (diff)
downloadaur-56be3d1c6b9a38ce6001de7ce715fd64f7e0f61f.tar.gz
bump for python 3.11 rebuild
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7cc47822544e..281fc55fd5ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = python-numpy-groupies
pkgdesc = Optimised tools for group-indexing operations for python numpy
pkgver = 0.9.20
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ml31415/numpy-groupies
arch = any
license = BSD
- makedepends = python-pytest-runner
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
depends = python-numpy
optdepends = python-numba: for numba backend
optdepends = python-pandas: for pandas backend
diff --git a/PKGBUILD b/PKGBUILD
index 5e50e363b2f7..c0adfa186694 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=python-numpy-groupies
_name=numpy-groupies
pkgver=0.9.20
-pkgrel=1
+pkgrel=2
pkgdesc='Optimised tools for group-indexing operations for python numpy'
arch=("any")
url="https://github.com/ml31415/numpy-groupies"
license=('BSD')
depends=('python-numpy')
-makedepends=('python-pytest-runner')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
optdepends=(
'python-numba: for numba backend'
'python-pandas: for pandas backend'
@@ -19,12 +19,12 @@ sha256sums=('1c651930de328e88c7cd0685df96a1d8314ec0c9444816f8fbfe6689275e8fd3')
build() {
cd "${_name}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_name}-${pkgver}"
- python setup.py install --root "${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}