summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-09-23 19:39:16 +0200
committera8212023-09-23 19:39:16 +0200
commit7b74032c529028e2c9a2f07bb96c73733208cc99 (patch)
tree3e85bd3eb06beb851e00e1837ec9d9a0533eeb23
parente7f2f7b78f4c5892b2f6d092cb1b002f56db830c (diff)
downloadaur-7b74032c529028e2c9a2f07bb96c73733208cc99.tar.gz
Version 0.10.1
switch to git sources because versioning requires a git repo.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a3c45a85f00..327ddb6a3f1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = python-numpy-groupies
pkgdesc = Optimised tools for group-indexing operations for python numpy
- pkgver = 0.9.22
- pkgrel = 2
+ pkgver = 0.10.1
+ pkgrel = 1
url = https://github.com/ml31415/numpy-groupies
arch = any
license = BSD
+ makedepends = git
makedepends = python-build
makedepends = python-installer
- makedepends = python-setuptools
+ makedepends = python-setuptools-scm
makedepends = python-wheel
depends = python-numpy
optdepends = python-numba: for numba backend
optdepends = python-pandas: for pandas backend
- source = python-numpy-groupies-0.9.22.tar.gz::https://github.com/ml31415/numpy-groupies/archive/refs/tags/v0.9.22.tar.gz
- sha256sums = ca02e859fc5e13a9be722aca4dd83dc29f30786cae935917fca1d39673ede37c
+ source = git+https://github.com/ml31415/numpy-groupies.git#commit=dbae25b2bbb20a66ca08d2908af54e868847db11
+ sha256sums = SKIP
pkgname = python-numpy-groupies
diff --git a/PKGBUILD b/PKGBUILD
index 0d6e821d8ceb..056f08ce50dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,29 @@
pkgname=python-numpy-groupies
_name=numpy-groupies
-pkgver=0.9.22
-pkgrel=2
+pkgver=0.10.1
+pkgrel=1
pkgdesc='Optimised tools for group-indexing operations for python numpy'
arch=("any")
url="https://github.com/ml31415/numpy-groupies"
license=('BSD')
depends=('python-numpy')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-wheel')
optdepends=(
'python-numba: for numba backend'
'python-pandas: for pandas backend'
)
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('ca02e859fc5e13a9be722aca4dd83dc29f30786cae935917fca1d39673ede37c')
+_commit=dbae25b2bbb20a66ca08d2908af54e868847db11
+source=("git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
build() {
- cd "${_name}-${pkgver}"
+ cd "${_name}"
python -m build --wheel --no-isolation
}
package() {
- cd "${_name}-${pkgver}"
+ cd "${_name}"
python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}