summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212021-09-08 22:42:24 +0200
committera8212021-09-08 22:42:24 +0200
commitbc442c2530c0513c981183e08f4c9a1581378cab (patch)
tree2e9a52df66dcb13e169f6b627c9ac88eca256a73
parent4f3f00d7871e8fcf2a62b19ec7f90d5adcfbe412 (diff)
downloadaur-bc442c2530c0513c981183e08f4c9a1581378cab.tar.gz
Version 0.9.14
Change build depencency to pytest-runner as stated in setup.py
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d523277e733d..7d99e6fb9626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-numpy-groupies
pkgdesc = Optimised tools for group-indexing operations for python numpy
- pkgver = 0.9.13
- pkgrel = 2
+ pkgver = 0.9.14
+ pkgrel = 1
url = https://github.com/ml31415/numpy-groupies
arch = any
license = BSD
- makedepends = python-setuptools
+ makedepends = python-pytest-runner
depends = python-numpy
optdepends = python-numba: for numba backend
optdepends = python-pandas: for pandas backend
- source = python-numpy-groupies-0.9.13.tar.gz::https://github.com/ml31415/numpy-groupies/archive/v0.9.13.tar.gz
- sha256sums = 5f3c2d62dcf83fb24f842440c2db78327eaf7d5459f6c864c582d03047066828
+ source = python-numpy-groupies-0.9.14.tar.gz::https://files.pythonhosted.org/packages/source/n/numpy_groupies/numpy_groupies-0.9.14.tar.gz
+ sha256sums = 01b7aeca60e643db34875c9823ea6775742adafe5bb406bca14367743ef81800
pkgname = python-numpy-groupies
-
diff --git a/PKGBUILD b/PKGBUILD
index c6632a1ecc2c..b64e33379c20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
# Maintainer: a821 <a821 - mail - de>
pkgname=python-numpy-groupies
-pkgver=0.9.13
-pkgrel=2
+_name=numpy_groupies
+pkgver=0.9.14
+pkgrel=1
pkgdesc='Optimised tools for group-indexing operations for python numpy'
arch=("any")
url="https://github.com/ml31415/numpy-groupies"
license=('BSD')
depends=('python-numpy')
-makedepends=('python-setuptools')
+makedepends=('python-pytest-runner')
optdepends=(
'python-numba: for numba backend'
'python-pandas: for pandas backend'
)
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('5f3c2d62dcf83fb24f842440c2db78327eaf7d5459f6c864c582d03047066828')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('01b7aeca60e643db34875c9823ea6775742adafe5bb406bca14367743ef81800')
build() {
- cd "${pkgname/python-}-${pkgver}"
+ cd "${_name}-${pkgver}"
python setup.py build
}
package() {
- cd "${pkgname/python-}-${pkgver}"
+ cd "${_name}-${pkgver}"
python setup.py install --root "${pkgdir}" --optimize=1
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}