summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212022-07-31 18:32:48 +0200
committera8212022-07-31 18:32:48 +0200
commite43e1ebf2b13e626e8445e6b0f8408e4fed0d2a5 (patch)
tree67e111e17de6808e3767caff34960d4b6703dbc8
parent1d8b451177a2d00bb3631baf1f4a133dbb9543ec (diff)
downloadaur-e43e1ebf2b13e626e8445e6b0f8408e4fed0d2a5.tar.gz
Version 0.9.18
+ Change sources to github because this pkg is missing in pypi + Add .gitignore
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3ec952c9f526..9aed84f43192 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-numpy-groupies
pkgdesc = Optimised tools for group-indexing operations for python numpy
- pkgver = 0.9.17
+ pkgver = 0.9.18
pkgrel = 1
url = https://github.com/ml31415/numpy-groupies
arch = any
@@ -9,7 +9,7 @@ pkgbase = python-numpy-groupies
depends = python-numpy
optdepends = python-numba: for numba backend
optdepends = python-pandas: for pandas backend
- source = python-numpy-groupies-0.9.17.tar.gz::https://files.pythonhosted.org/packages/source/n/numpy_groupies/numpy_groupies-0.9.17.tar.gz
- sha256sums = de9390b1e5e4d84c27f0f520158b4ee8afb91035972d8e22dd0aea00f5588e3a
+ source = python-numpy-groupies-0.9.18.tar.gz::https://github.com/ml31415/numpy-groupies/archive/refs/tags/v0.9.18.tar.gz
+ sha256sums = ea845a9acb533e3ba011826c48e7abe27dd1895edb3bfa09322bc12803982e1a
pkgname = python-numpy-groupies
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1970994f527a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.SRCINFO
+!/.gitignore
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index d69f03ebf500..4b8e19aba32d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: a821 <a821 - mail - de>
pkgname=python-numpy-groupies
-_name=numpy_groupies
-pkgver=0.9.17
+_name=numpy-groupies
+pkgver=0.9.18
pkgrel=1
pkgdesc='Optimised tools for group-indexing operations for python numpy'
arch=("any")
@@ -14,8 +14,8 @@ optdepends=(
'python-numba: for numba backend'
'python-pandas: for pandas backend'
)
-source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
-sha256sums=('de9390b1e5e4d84c27f0f520158b4ee8afb91035972d8e22dd0aea00f5588e3a')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('ea845a9acb533e3ba011826c48e7abe27dd1895edb3bfa09322bc12803982e1a')
build() {
cd "${_name}-${pkgver}"