summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Riva2017-06-17 13:36:47 +0200
committerSimone Riva2017-06-17 13:36:47 +0200
commit772ba6f7da9afdb7a6c0839f994858f58476957e (patch)
tree41e7e5c98de168c3cebc6f59caa447cf54d07aeb
parentaa4e17349058fba0c47635df43320e0da9f232b0 (diff)
downloadaur-772ba6f7da9afdb7a6c0839f994858f58476957e.tar.gz
1.13.0-3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
-rw-r--r--__init__2.py.patch2
-rw-r--r--__init__3.py.patch2
-rw-r--r--intel.py1
5 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5445b65e8c6e..e82ddca9b2c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-numpy-mkl
pkgdesc = Scientific tools for Python compiled with intel mkl
pkgver = 1.13.0
- pkgrel = 2
+ pkgrel = 3
url = http://numpy.scipy.org/
arch = i686
arch = x86_64
@@ -20,17 +20,17 @@ pkgbase = python-numpy-mkl
source = https://github.com/numpy/numpy/archive/v1.13.0.tar.gz
source = site64.cfg
source = site32.cfg
- source = intel.py
+ source = https://raw.githubusercontent.com/numpy/numpy/v1.13.0/numpy/distutils/fcompiler/intel.py
source = intelccompiler.py
source = __init__2.py.patch
source = __init__3.py.patch
sha256sums = dbbaaf3e86d0d138d42c61b1243d580bd6351088f0bcf2e44a7374c4559a1845
sha256sums = 86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1
sha256sums = 882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df
- sha256sums = 98da2098f512f2e69d72e58cf1675c9125aef6f7118fce0d985b2c817312e12d
+ sha256sums = e289b6cbb552c547678818172b35cda58064bd39ec2b084c6390142ddf02c4f9
sha256sums = a3faf52563f265b8adbb912c6acf969787a9d423e960c877ea9abd128976f814
- sha256sums = 257adf2130c2cde081da61ac38d3fbce0c352d9b4af206d89d7a7e77c54b264a
- sha256sums = 257adf2130c2cde081da61ac38d3fbce0c352d9b4af206d89d7a7e77c54b264a
+ sha256sums = 867e27caa396490e594c269ee24cc8f887a759fccf1f7e507690188f3f84e6f7
+ sha256sums = 867e27caa396490e594c269ee24cc8f887a759fccf1f7e507690188f3f84e6f7
pkgname = python-numpy-mkl
depends = intel-mkl
diff --git a/PKGBUILD b/PKGBUILD
index 2a94dd65438a..37b57c86ef23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgname="python-numpy-mkl"
true && pkgname=('python-numpy-mkl' 'python2-numpy-mkl')
#pkgname=('python-numpy')
pkgver=1.13.0
-pkgrel=2
+pkgrel=3
pkgdesc="Scientific tools for Python compiled with intel mkl"
arch=('i686' 'x86_64')
license=('custom')
@@ -18,15 +18,20 @@ depends=( 'intel-mkl' 'python' 'python2' )
makedepends=( 'python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'python-nose' 'python2-nose' 'cython' )
source=( https://github.com/numpy/numpy/archive/v${pkgver}.tar.gz
- 'site64.cfg' 'site32.cfg' 'intel.py' 'intelccompiler.py' '__init__2.py.patch' '__init__3.py.patch' )
-
-sha256sums=( 'dbbaaf3e86d0d138d42c61b1243d580bd6351088f0bcf2e44a7374c4559a1845'
- '86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1'
- '882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df'
- '98da2098f512f2e69d72e58cf1675c9125aef6f7118fce0d985b2c817312e12d'
- 'a3faf52563f265b8adbb912c6acf969787a9d423e960c877ea9abd128976f814'
- '257adf2130c2cde081da61ac38d3fbce0c352d9b4af206d89d7a7e77c54b264a'
- '257adf2130c2cde081da61ac38d3fbce0c352d9b4af206d89d7a7e77c54b264a'
+ 'site64.cfg'
+ 'site32.cfg'
+ https://raw.githubusercontent.com/numpy/numpy/v${pkgver}/numpy/distutils/fcompiler/intel.py
+ 'intelccompiler.py'
+ '__init__2.py.patch'
+ '__init__3.py.patch' )
+
+sha256sums=( 'dbbaaf3e86d0d138d42c61b1243d580bd6351088f0bcf2e44a7374c4559a1845' # main pkg§
+ '86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1' # site64
+ '882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df' # site32
+ 'e289b6cbb552c547678818172b35cda58064bd39ec2b084c6390142ddf02c4f9' # intel.py
+ 'a3faf52563f265b8adbb912c6acf969787a9d423e960c877ea9abd128976f814' # intelccompiler.py
+ '867e27caa396490e594c269ee24cc8f887a759fccf1f7e507690188f3f84e6f7' # __init__2.py.patch
+ '867e27caa396490e594c269ee24cc8f887a759fccf1f7e507690188f3f84e6f7' # __init__3.py.patch
)
build() {
diff --git a/__init__2.py.patch b/__init__2.py.patch
index 9f0d64698950..f3c60077a9d8 100644
--- a/__init__2.py.patch
+++ b/__init__2.py.patch
@@ -4,4 +4,4 @@
---
> pass
> #raise CompilerNotFound()
-> return '13.0'
+> return '17.0'
diff --git a/__init__3.py.patch b/__init__3.py.patch
index 9f0d64698950..f3c60077a9d8 100644
--- a/__init__3.py.patch
+++ b/__init__3.py.patch
@@ -4,4 +4,4 @@
---
> pass
> #raise CompilerNotFound()
-> return '13.0'
+> return '17.0'
diff --git a/intel.py b/intel.py
index 0616317d7a05..eb6150201c2e 100644
--- a/intel.py
+++ b/intel.py
@@ -219,4 +219,3 @@ if __name__ == '__main__':
compiler = new_fcompiler(compiler='intel')
compiler.customize()
print(compiler.get_version())
-