summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Riva2017-10-07 18:48:41 +0200
committerSimone Riva2017-10-07 18:48:41 +0200
commit9feb1ee4f95c7fe57138f3fc0a677a8bcc54ce75 (patch)
tree1f929c8fa37eded15c495376a67ea8a95cd5d549
parent324a8734f22a6c3ff3638942dfaa5e9341b49dfa (diff)
downloadaur-9feb1ee4f95c7fe57138f3fc0a677a8bcc54ce75.tar.gz
v1.13.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ed5226aaed36..c39d39aef0ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-numpy-mkl
pkgdesc = Scientific tools for Python compiled with intel mkl
- pkgver = 1.13.2
+ pkgver = 1.13.3
pkgrel = 1
url = http://numpy.scipy.org/
arch = i686
@@ -13,23 +13,23 @@ pkgbase = python-numpy-mkl
makedepends = python-nose
makedepends = python2-nose
makedepends = cython
- makedepends = glibc<2.26
+ makedepends = glibc
depends = intel-mkl
depends = python
depends = python2
options = staticlibs
- source = https://github.com/numpy/numpy/archive/v1.13.2.tar.gz
+ source = https://github.com/numpy/numpy/archive/v1.13.3.tar.gz
source = site64.cfg
source = site32.cfg
- sha256sums = 11add7a40a868e70b7de8e568e5f20504f4dbfc7fce18887472220c2f5167ae4
+ sha256sums = 1db97b12ea8f2ae5a8b847505f634dcd8c670ee311057ff5412a126becca45b8
sha256sums = 86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1
sha256sums = 882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df
pkgname = python-numpy-mkl
depends = intel-mkl
depends = python
- provides = python3-numpy=1.13.2
- provides = python-numpy=1.13.2
+ provides = python3-numpy=1.13.3
+ provides = python-numpy=1.13.3
conflicts = python3-numpy
conflicts = python-numpy
replaces = python3-numpy
@@ -38,7 +38,7 @@ pkgname = python2-numpy-mkl
depends = intel-mkl
depends = python2
optdepends = python-nose: testsuite
- provides = python2-numpy=1.13.2
+ provides = python2-numpy=1.13.3
conflicts = python2-numpy
replaces = python2-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 3e725fbb0042..b7339f811921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgbase="python-numpy-mkl"
pkgname="python-numpy-mkl"
true && pkgname=('python-numpy-mkl' 'python2-numpy-mkl')
#pkgname=('python-numpy')
-pkgver=1.13.2
+pkgver=1.13.3
pkgrel=1
pkgdesc="Scientific tools for Python compiled with intel mkl"
arch=('i686' 'x86_64')
@@ -15,13 +15,13 @@ license=('custom')
options=('staticlibs')
url="http://numpy.scipy.org/"
depends=( 'intel-mkl' 'python' 'python2' )
-makedepends=( 'python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'python-nose' 'python2-nose' 'cython' 'glibc<2.26' )
+makedepends=( 'python-setuptools' 'python2-setuptools' 'intel-compiler-base' 'intel-fortran-compiler' 'python-nose' 'python2-nose' 'cython' 'glibc' )
source=( https://github.com/numpy/numpy/archive/v${pkgver}.tar.gz
'site64.cfg'
'site32.cfg')
-sha256sums=( '11add7a40a868e70b7de8e568e5f20504f4dbfc7fce18887472220c2f5167ae4' # main pkg§
+sha256sums=( '1db97b12ea8f2ae5a8b847505f634dcd8c670ee311057ff5412a126becca45b8' # main pkg§
'86cd68a695a5e1d76f8e53cda70c888c4ed04349f15c8096d4492e346e7187e1' # site64
'882f2717deca0fd6a2e2384aac2dc7973c566f9cd2ba46777c3b5ffdffa814df' # site32
)
@@ -44,11 +44,15 @@ cp -a numpy-${pkgver} numpy-py2-${pkgver}
export Atlas=None
export LDFLAGS="$LDFLAGS -shared"
+export __INTEL_PRE_CFLAGS="$__INTEL_PRE_CFLAGS -D_Float128=__float128"
+
+
echo "Building Python2"
cd "${srcdir}"
cp ${srcdir}/site.cfg "${srcdir}/numpy-py2-${pkgver}"
cd "${srcdir}/numpy-py2-${pkgver}"
+
python2 setup.py config --compiler=${_compiler} build_clib --compiler=${_compiler} build_ext --compiler=${_compiler}
echo "Building Python3"
@@ -56,6 +60,7 @@ cd "${srcdir}"
cp ${srcdir}/site.cfg "${srcdir}/numpy-${pkgver}"
cd "${srcdir}/numpy-${pkgver}"
+
python setup.py config --compiler=${_compiler} build_clib --compiler=${_compiler} build_ext --compiler=${_compiler}
}