summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmwang2022-01-11 13:11:52 -0800
committerlmwang2022-01-11 13:11:52 -0800
commit2824b3a0790bf18625c802ed2e05a14d32c099cd (patch)
tree4f02a72e1fc625bb9f66ac7733c580ea1875b431
parentfa86c90f87763644acf2979ee2d33aa1082ca2f8 (diff)
downloadaur-2824b3a0790bf18625c802ed2e05a14d32c099cd.tar.gz
replaced hard-coded python version
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cc539828c85..ee1483550b80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-numpy-openblas
pkgdesc = Scientific tools for Python - built with openblas
pkgver = 1.22.0
- pkgrel = 1
+ pkgrel = 2
url = http://numpy.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 948f425dc166..2966eb316fad 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname="python-numpy-openblas"
pkgver=1.22.0
-pkgrel=1
+pkgrel=2
pkgdesc="Scientific tools for Python - built with openblas"
arch=("i686" "x86_64")
license=("custom")
@@ -30,7 +30,6 @@ build() {
export Atlas=None
export LDFLAGS="$LDFLAGS -shared"
-
cd numpy-$pkgver
NPY_BLAS_ORDER=openblas NPY_LAPACK_ORDER=openblas python setup.py config_fc --fcompiler=gnu95 build
@@ -40,7 +39,8 @@ check() {
cd numpy-$pkgver
python setup.py install --root="$PWD/tmp_install" --optimize=1
cd "$PWD/tmp_install"
- PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/python3.10/site-packages:$PYTHONPATH" python -c 'import numpy; numpy.test()'
+ local python_version=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+ PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/${python_version}/site-packages:$PYTHONPATH" python -c 'import numpy; numpy.test()'
}
package() {