summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlmwang2019-11-15 20:20:23 -0800
committerlmwang2019-11-15 20:20:23 -0800
commitca77a5a2e2984577fe4db80c7ce8d8c81a7e55a0 (patch)
treec35b59444cd42b560862e898728fd4c235ea2aec
parent146c24dd320f9e2855a3a46e5899a1b793c0d459 (diff)
downloadaur-ca77a5a2e2984577fe4db80c7ce8d8c81a7e55a0.tar.gz
rebuild for python3.8
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD34
2 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6c73c262ef5..37814477f545 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-numpy-openblas
pkgdesc = Scientific tools for Python - built with openblas
pkgver = 1.17.4
- pkgrel = 1
+ pkgrel = 2
url = http://numpy.scipy.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9969df3bb757..6691211fe2ec 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname="python-numpy-openblas"
pkgver=1.17.4
-pkgrel=1
+pkgrel=2
pkgdesc="Scientific tools for Python - built with openblas"
arch=("i686" "x86_64")
license=("custom")
@@ -21,36 +21,32 @@ options=('staticlibs')
source=("python-numpy-$pkgver.tar.gz::https://github.com/numpy/numpy/releases/download/v$pkgver/numpy-$pkgver.tar.gz")
sha256sums=('fb0415475e673cb9a6dd816df999e0ab9f86fa3af2b1770944e7288d2bea4ac9')
+build() {
+ export Atlas=None
+ export LDFLAGS="$LDFLAGS -shared"
+
+ echo "Building Python3"
+ cd numpy-$pkgver
+
+ python setup.py config_fc --fcompiler=gnu95 build
+}
+
check() {
# TODO: Fix fortran tests here (it works fine after installation)
- cd "$srcdir"/numpy-$pkgver
- python setup.py config_fc --fcompiler=gnu95 install --root="$PWD/tmp_install" --optimize=1
+ cd numpy-$pkgver
+ python setup.py install --root="$PWD/tmp_install" --optimize=1
cd "$PWD/tmp_install"
- PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/python3.7/site-packages:$PYTHONPATH" python -c 'import numpy; numpy.test()'
-
+ PATH="$PWD/usr/bin:$PATH" PYTHONPATH="$PWD/usr/lib/python3.8/site-packages:$PYTHONPATH" python -c 'import numpy; numpy.test()'
}
package() {
- _pyver=3.7
- _pyinc=3.7m
-
- export Atlas=None
- export LDFLAGS="$LDFLAGS -shared"
-
- echo "Building Python3"
- cd "$srcdir/numpy-$pkgver"
-
- python setup.py config_fc --fcompiler=gnu95 build
+ cd numpy-$pkgver
python setup.py config_fc --fcompiler=gnu95 install \
--prefix=/usr --root="${pkgdir}" --optimize=1
install -m755 -d "${pkgdir}/usr/share/licenses/python-numpy"
install -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-numpy/"
-
- install -m755 -d "${pkgdir}/usr/include/python${_pyinc}"
- ln -sf /usr/lib/python${_pyver}/site-packages/numpy/core/include/numpy "${pkgdir}/usr/include/python${_pyinc}/numpy"
-
}