summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-26 21:32:41 -0500
committerCarlos Aznarán Laos2022-10-26 21:32:41 -0500
commit83deaf2684e288aa86cc67ca80fce4b553f419fd (patch)
tree1cf6481c90f7befdefeb369652a81a612cec9017
parent41b70751c8872545a1e27ef5cf1d89281010a358 (diff)
downloadaur-83deaf2684e288aa86cc67ca80fce4b553f419fd.tar.gz
Change python-install by python-installer
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b5f6574e831..de31fbc91a3d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-nutils-si-git
pkgdesc = Framework for physical units
- pkgver = 20211230
+ pkgver = 20220909
pkgrel = 1
url = https://github.com/evalf/nutils-SI
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = python-nutils-si-git
checkdepends = python-pytest
makedepends = python-build
makedepends = python-flit-core
- makedepends = python-install
+ makedepends = python-installer
makedepends = git
depends = python
provides = python-nutils-si
diff --git a/PKGBUILD b/PKGBUILD
index 787d7f500560..ba31ab16251a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
_base=nutils-SI
pkgname=python-${_base,,}-git
pkgdesc="Framework for physical units"
-pkgver=20211230
+pkgver=20220909
pkgrel=1
arch=('x86_64')
url="https://github.com/evalf/${_base}"
license=(MIT)
depends=(python)
-makedepends=(python-build python-flit-core python-install git)
+makedepends=(python-build python-flit-core python-installer git)
checkdepends=(python-numpy python-pytest)
source=(git+${url}.git#branch=main)
sha512sums=('SKIP')
@@ -22,20 +22,19 @@ pkgver() {
build() {
cd ${_base}
- export PYTHONHASHSEED=0
python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
cd ${_base}
python -m venv --system-site-packages test-env
- test-env/bin/python -m install --optimize=1 dist/*.whl
+ test-env/bin/python -m installer dist/*.whl
test-env/bin/python -m pytest
}
package() {
cd ${_base}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")