summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2017-12-06 23:24:35 -0700
committerAinola2017-12-06 23:24:35 -0700
commitb44367379cc5befdaebf108474154df35c2b321c (patch)
tree9df2384e36d74501ca43bf8ec5ceeb69858a3802
downloadaur-b44367379cc5befdaebf108474154df35c2b321c.tar.gz
initial
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4cb0ae8327b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Dec 7 06:24:26 UTC 2017
+pkgbase = python-oath
+ pkgdesc = Python implementation of HOTP, TOTP and OCRA algorithms from OATH.
+ pkgver = 1.4.0
+ pkgrel = 1
+ url = https://github.com/bdauvergne/python-oath
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/bdauvergne/python-oath/archive/v1.4.0.tar.gz
+ sha256sums = 3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f
+
+pkgname = python-oath
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c738cb3d8104
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Ainola
+
+pkgname=python-oath
+pkgver=1.4.0
+pkgrel=1
+pkgdesc="Python implementation of HOTP, TOTP and OCRA algorithms from OATH."
+arch=('any')
+url="https://github.com/bdauvergne/python-oath"
+license=('BSD')
+makedepends=('python-setuptools')
+depends=('python')
+source=("https://github.com/bdauvergne/python-oath/archive/v$pkgver.tar.gz")
+sha256sums=('3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f')
+
+build() {
+ cd "$srcdir/python-oath-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/python-oath-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+