summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-12-12 17:44:38 -0700
committerAinola2018-12-12 17:44:38 -0700
commitb8b79737e00c876ad45bd08069b9d32ed41017cd (patch)
tree87b9eb5e202dd57d1362874218de85092bcfcfb6
parent865822e0e492cc354285b5e4154ca7685f69cd0a (diff)
downloadaur-b8b79737e00c876ad45bd08069b9d32ed41017cd.tar.gz
upgpkg: 1.4.1, switch to pypi
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b4938da3567..fa53e91c29c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-oath
pkgdesc = Python implementation of HOTP, TOTP and OCRA algorithms from OATH.
- pkgver = 1.4.0
+ pkgver = 1.4.1
pkgrel = 7
url = https://github.com/bdauvergne/python-oath
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = python-oath-1.4.0::https://github.com/bdauvergne/python-oath/archive/v1.4.0.tar.gz
- sha256sums = 3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f
+ source = python-oath-1.4.1.tar.gz::https://pypi.io/packages/source/o/oath/oath-1.4.1.tar.gz
+ sha256sums = 60f59ead7dfe56c49e98ace4d4abab1b62fe65b657d3bfeebb60b322c0be30db
pkgname = python-oath
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index c9b36eb87c08..17a2e60b70a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,33 @@
pkgbase=python-oath
pkgname=('python-oath' 'python2-oath')
-pkgver=1.4.0
+pkgver=1.4.1
pkgrel=7
pkgdesc="Python implementation of HOTP, TOTP and OCRA algorithms from OATH."
arch=('any')
url="https://github.com/bdauvergne/python-oath"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools')
-source=("$pkgname-$pkgver::https://github.com/bdauvergne/python-oath/archive/v$pkgver.tar.gz")
-sha256sums=('3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f')
+source=("$pkgname-$pkgver.tar.gz::https://pypi.io/packages/source/o/oath/oath-$pkgver.tar.gz")
+sha256sums=('60f59ead7dfe56c49e98ace4d4abab1b62fe65b657d3bfeebb60b322c0be30db')
prepare() {
- cp -a "python-oath-$pkgver"{,-py2}
+ cp -a "oath-$pkgver"{,-py2}
}
build() {
- cd "python-oath-$pkgver" && python setup.py build
- cd "../python-oath-$pkgver-py2" && python2 setup.py build
+ cd "oath-$pkgver" && python setup.py build
+ cd "../oath-$pkgver-py2" && python2 setup.py build
}
check() {
- cd "python-oath-$pkgver" && python setup.py test
- cd "../python-oath-$pkgver-py2" && python2 setup.py test
+ cd "oath-$pkgver" && python setup.py test
+ cd "../oath-$pkgver-py2" && python2 setup.py test
}
package_python-oath() {
depends=('python')
- cd "python-oath-$pkgver"
+ cd "oath-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 doc/* -t "$pkgdir/usr/share/doc/$pkgname/"
@@ -36,7 +36,7 @@ package_python-oath() {
package_python2-oath() {
depends=('python2')
- cd "python-oath-$pkgver-py2"
+ cd "oath-$pkgver-py2"
python2 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 COPYING -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 doc/* -t "$pkgdir/usr/share/doc/$pkgname/"