summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-09-09 16:19:05 -0600
committerAinola2018-09-09 16:19:05 -0600
commitcd92e697d18e784de7cc370abefb9bce94545baa (patch)
treea0adac492a2ccfe6c765991bec9c8114a637dd0e
parent28bb5be710a19728be97f7e7a4c6df25d52e35cc (diff)
downloadaur-cd92e697d18e784de7cc370abefb9bce94545baa.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 362a0b1852fc..eaa4ae0bf295 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
# Generated by mksrcinfo v8
-# Mon Sep 3 17:26:55 UTC 2018
+# Sun Sep 9 22:18:55 UTC 2018
pkgbase = python-oath
pkgdesc = Python implementation of HOTP, TOTP and OCRA algorithms from OATH.
pkgver = 1.4.0
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/bdauvergne/python-oath
arch = any
license = BSD
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/bdauvergne/python-oath/archive/v1.4.0.tar.gz
+ source = python-oath-1.4.0::https://github.com/bdauvergne/python-oath/archive/v1.4.0.tar.gz
sha256sums = 3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f
pkgname = python-oath
diff --git a/PKGBUILD b/PKGBUILD
index 01a1314824ee..deafc2a71e5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgbase=python-oath
pkgname=('python-oath' 'python2-oath')
pkgver=1.4.0
-pkgrel=5
+pkgrel=6
pkgdesc="Python implementation of HOTP, TOTP and OCRA algorithms from OATH."
arch=('any')
url="https://github.com/bdauvergne/python-oath"
license=('BSD')
makedepends=('python-setuptools' 'python2-setuptools')
-source=("https://github.com/bdauvergne/python-oath/archive/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver::https://github.com/bdauvergne/python-oath/archive/v$pkgver.tar.gz")
sha256sums=('3e485d0fc4a6c077cb75841cba6512c1ab1b11d766969a24b199586e04e7c58f')
prepare() {
@@ -17,8 +17,8 @@ prepare() {
}
build() {
- cd "$srcdir/python-oath-$pkgver" && python setup.py build
- cd "$srcdir/python-oath-$pkgver-py2" && python2 setup.py build
+ cd "python-oath-$pkgver" && python setup.py build
+ cd "../python-oath-$pkgver-py2" && python2 setup.py build
}
package_python-oath() {