summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-10-11 02:40:43 +0100
committerGrey Christoforo2019-10-11 02:40:43 +0100
commita281762b5db7bffbb61ee296dc97f5c94387c275 (patch)
tree3e83603a2e7dd1cc16c5cb5ac1ee62eba863cfe1
parent233df006cff1b6aeef6e3a5410de5cff0e877649 (diff)
downloadaur-a281762b5db7bffbb61ee296dc97f5c94387c275.tar.gz
build agent.js
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b62f2a99561..edbab7f13db7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,7 @@ pkgbase = python-objection
depends = python-tabulate
depends = python-prompt_toolkit
depends = python-delegator
+ depends = nodejs
source = https://github.com/sensepost/objection/archive/1.7.5.tar.gz
sha256sums = f3caee908f98e3ed2fe5c4e1555c2a85e371aadde8d273b033f5bcbd52617419
diff --git a/PKGBUILD b/PKGBUILD
index e0ff785fdbb7..ef2f8dcd8b56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="runtime mobile exploration"
arch=('any')
url=https://github.com/sensepost/objection
license=('GPLv3')
-depends=(python python-flask python-click python-frida python-frida-tools python-tabulate python-prompt_toolkit python-delegator)
+depends=(python python-flask python-click python-frida python-frida-tools python-tabulate python-prompt_toolkit python-delegator nodejs)
makedepends=('python-setuptools')
source=(https://github.com/sensepost/objection/archive/${pkgver}.tar.gz)
sha256sums=('f3caee908f98e3ed2fe5c4e1555c2a85e371aadde8d273b033f5bcbd52617419')
@@ -20,14 +20,17 @@ prepare() {
build() {
cd "$srcdir/objection-$pkgver/"
python setup.py build
-}
+ cd agent
+ npm install
+}
package() {
cd "$srcdir/objection-$pkgver/"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
cd "${pkgdir}"
find . -name tests | xargs rm -rf
+ cp "${srcdir}/objection-${pkgver}/objection/agent.js" "$(find . -name objection -type d)/."
}
# vim:ts=2:sw=2:et: