summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-11-10 17:45:10 +0100
committerGrey Christoforo2020-11-10 17:45:10 +0100
commite4a42d6d70d0a74a465a48484801f9c8ed373fbc (patch)
tree9230bd987eb92de4fb9b9ff0ddb4ceb48a6cada4
parent6ad26d70527beb2f4663f9297231c5b7531a538d (diff)
downloadaur-e4a42d6d70d0a74a465a48484801f9c8ed373fbc.tar.gz
check() works
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75df33e8e8d8..f1f8e36e289c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,11 +26,11 @@ build() {
check(){
cd pythonocc-core-${pkgver}/build
- #mkdir tmp
- #make DESTDIR=tmp install
- #cd pythonocc-core-${pkgver}/test
+ mkdir tmp
+ make DESTDIR=tmp install
+ _i_dir="$(python -c 'import sys; print(sys.path[-1])')"
- #python run_tests.py
+ PYTHONPATH="tmp/${_i_dir}" python "${srcdir}/pythonocc-core-${pkgver}/test/run_tests.py"
}