summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2018-07-27 23:14:40 -0400
committerAndrew O'Neill2018-07-27 23:14:40 -0400
commit0b9c3d24e87086a168271d3f2495ba7babc47c9d (patch)
treec6938f74792e59569dc8b0320458fa562236ca69
parent417a28452a51d7dd1f78bee50039bf1bd01dac35 (diff)
downloadaur-0b9c3d24e87086a168271d3f2495ba7babc47c9d.tar.gz
Woops, need to leave out configparser since that causes problems
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--python-oci.patch5
3 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90a2a1a2374a..42ae94dcef6a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-oci
pkgdesc = Python SDK for Oracle Cloud Infrastructure
pkgver = 2.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/oracle/oci-python-sdk
arch = any
license = Apache
@@ -19,7 +19,7 @@ pkgbase = python-oci
source = https://github.com/oracle/oci-python-sdk/archive/v2.0.0.tar.gz
source = python-oci.patch
sha256sums = 6ad20c543638af6987a8c9cbec2be08746a15ab168222cffb3d6654d4cc66501
- sha256sums = 82d5526ade9d556503d9e09eb39f9d81b00bcf3f9eee9f2bc36598a6f738cb19
+ sha256sums = 65d2a7d3b78033f22f609fe98cc9f07333ddd3529b4a738da9fa659265976ffe
pkgname = python-oci
diff --git a/PKGBUILD b/PKGBUILD
index 4602be82583c..7104cdb1e2a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-oci
_pyname=oci-python-sdk
pkgver=2.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='Python SDK for Oracle Cloud Infrastructure'
arch=('any')
url='https://github.com/oracle/oci-python-sdk'
@@ -13,7 +13,7 @@ makedepends=('python-setuptools')
source=("${url}/archive/v${pkgver}.tar.gz"
"${pkgname}.patch")
sha256sums=('6ad20c543638af6987a8c9cbec2be08746a15ab168222cffb3d6654d4cc66501'
- '82d5526ade9d556503d9e09eb39f9d81b00bcf3f9eee9f2bc36598a6f738cb19')
+ '65d2a7d3b78033f22f609fe98cc9f07333ddd3529b4a738da9fa659265976ffe')
prepare() {
cd "${_pyname}-${pkgver}"
diff --git a/python-oci.patch b/python-oci.patch
index cd3bbd605687..26ce7fe3b912 100644
--- a/python-oci.patch
+++ b/python-oci.patch
@@ -1,7 +1,7 @@
diff -rupN oci-python-sdk-2.0.0/setup.py oci-python-sdk-2.0.0b/setup.py
--- oci-python-sdk-2.0.0/setup.py 2018-07-26 18:04:41.000000000 -0400
-+++ oci-python-sdk-2.0.0b/setup.py 2018-07-27 21:49:08.261520223 -0400
-@@ -30,11 +30,11 @@ with open_relative("README.rst") as f:
++++ oci-python-sdk-2.0.0b/setup.py 2018-07-27 23:09:27.129796211 -0400
+@@ -30,11 +30,10 @@ with open_relative("README.rst") as f:
requires = [
"certifi",
@@ -10,7 +10,6 @@ diff -rupN oci-python-sdk-2.0.0/setup.py oci-python-sdk-2.0.0b/setup.py
- "pyOpenSSL<=17.4.0",
- "python-dateutil>=2.5.3,<=2.7.3",
- "pytz>=2016.10",
-+ "configparser",
+ "cryptography",
+ "pyOpenSSL",
+ "python-dateutil",